lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20250226222442.2a32d706@booty>
Date: Wed, 26 Feb 2025 22:24:42 +0100
From: Luca Ceresoli <luca.ceresoli@...tlin.com>
To: Jani Nikula <jani.nikula@...ux.intel.com>
Cc: Andrzej Hajda <andrzej.hajda@...el.com>, Neil Armstrong
 <neil.armstrong@...aro.org>, Robert Foss <rfoss@...nel.org>, Laurent
 Pinchart <Laurent.pinchart@...asonboard.com>, Jonas Karlman
 <jonas@...boo.se>, Jernej Skrabec <jernej.skrabec@...il.com>, Maarten
 Lankhorst <maarten.lankhorst@...ux.intel.com>, Maxime Ripard
 <mripard@...nel.org>, Thomas Zimmermann <tzimmermann@...e.de>, David Airlie
 <airlied@...il.com>, Simona Vetter <simona@...ll.ch>, Dmitry Baryshkov
 <dmitry.baryshkov@...aro.org>, Thomas Petazzoni
 <thomas.petazzoni@...tlin.com>, dri-devel@...ts.freedesktop.org,
 linux-kernel@...r.kernel.org
Subject: Re: [PATCH v7 1/2] drm/bridge: move bridges_show logic from
 drm_debugfs.c

Hello Jani,

On Wed, 26 Feb 2025 14:26:09 +0200
Jani Nikula <jani.nikula@...ux.intel.com> wrote:

> > Moving the last 2 lines to drm_bridge.c and into a new function we'd
> > have:
> >
> > drm_encoder_register_all()                             [drm_encoder.c]  
> >  -> drm_debugfs_encoder_add [*]                        [drm_debugfs.c]
> >   -> drm_bridge_debugfs_add_encoder_bridges_file (NEW) [drm_bridge.c]
> >    -> debugfs_create_file("bridges"...  &bridges_fops) [drm_bridge.c]  
> >                                     [bridges_fops is in drm_bridge.c]
> >
> > Potentially [*] could be moved to drm_encoder.c, but that is not bridge
> > related and can be done as a future step.
> >
> > Is this what you had in mind?  
> 
> Yes!
> 
> (Though I'd give drm_bridge_debugfs_add_encoder_bridges_file() a shorter
> and more generic name.)

Thanks, done. v8 on its way.

Luca

-- 
Luca Ceresoli, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ