[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250228151730.1874916-1-demonsingur@gmail.com>
Date: Fri, 28 Feb 2025 17:17:17 +0200
From: Cosmin Tanislav <demonsingur@...il.com>
To:
Cc: Wolfram Sang <wsa+renesas@...g-engineering.com>,
Tomi Valkeinen <tomi.valkeinen@...asonboard.com>,
Luca Ceresoli <luca.ceresoli@...tlin.com>,
Mauro Carvalho Chehab <mchehab@...nel.org>,
Romain Gantois <romain.gantois@...tlin.com>,
Arnd Bergmann <arnd@...db.de>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
linux-i2c@...r.kernel.org,
linux-kernel@...r.kernel.org,
linux-media@...r.kernel.org,
Cosmin Tanislav <demonsingur@...il.com>
Subject: [PATCH v3 0/9] i2c: atr: allow usage of nested ATRs
For upcoming GMSL drivers, we need to be able to use nested ATRs.
The deserializer changes the address of the serializers, and can only
do that for the serializers, while the serializers have proper address
translation hardware, and can translate the address of its children.
To achieve this, add a static flag and a passthrough flag.
The static flag prevents usage of dynamic remapping by disallowing
creation of new mappings outside of the attach_addr() function.
The passthrough flag prevents messages coming from non-direct children
(which don't have a local mapping) to be treated as erroneous.
This series also contains various fixes to the logic observed during
development.
This series depends on:
https://lore.kernel.org/lkml/20250227-fpc202-v8-0-b7994117fbe2@bootlin.com
The previous version is at:
https://lore.kernel.org/lkml/20250225113939.49811-1-demonsingur@gmail.com
V3:
* remove i2c_atr_new_flags(), add flags parameter to i2c_atr_new() in
a new patch
* remove "i2c: atr: unlock mutex after c2a access" patch as it will
be moved into the base series
* remove alias_pairs variable used only once
* remove err_del_c2a label used only once
* add lockdep_assert_held to i2c_atr_create_mapping_by_addr()
* I2C_ATR_STATIC -> I2C_ATR_F_STATIC
* I2C_ATR_PASSTHROUGH -> I2C_ATR_F_PASSTHROUGH
* add passthrough check to i2c_atr_smbus_xfer()
V2:
* rename and split up i2c_atr_find_mapping_by_addr() to allow for
usage of parts of its logic where applicable
Cosmin Tanislav (8):
i2c: atr: find_mapping() -> get_mapping()
i2c: atr: split up i2c_atr_get_mapping_by_addr()
i2c: atr: do not create mapping in detach_addr()
i2c: atr: deduplicate logic in attach_addr()
i2c: atr: allow replacing mappings in attach_addr()
i2c: atr: add flags parameter to i2c_atr_new()
i2c: atr: add static flag
i2c: atr: add passthrough flag
Tomi Valkeinen (1):
i2c: atr: Fix lockdep for nested ATRs
drivers/i2c/i2c-atr.c | 179 ++++++++++++++++++++++------------
drivers/media/i2c/ds90ub960.c | 2 +-
drivers/misc/ti_fpc202.c | 2 +-
include/linux/i2c-atr.h | 15 ++-
4 files changed, 133 insertions(+), 65 deletions(-)
--
2.48.1
Powered by blists - more mailing lists