[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <e6ab03fb87c14b1596c4f201485b49d0602c91b7.camel@linaro.org>
Date: Fri, 28 Feb 2025 11:37:30 +0000
From: André Draszik <andre.draszik@...aro.org>
To: Linus Walleij <linus.walleij@...aro.org>
Cc: Lee Jones <lee@...nel.org>, Rob Herring <robh@...nel.org>, Krzysztof
Kozlowski <krzk+dt@...nel.org>, Conor Dooley <conor+dt@...nel.org>, Bartosz
Golaszewski <brgl@...ev.pl>, Srinivas Kandagatla
<srinivas.kandagatla@...aro.org>, Kees Cook <kees@...nel.org>, "Gustavo A.
R. Silva" <gustavoars@...nel.org>, Peter Griffin
<peter.griffin@...aro.org>, Tudor Ambarus <tudor.ambarus@...aro.org>, Will
McVicker <willmcvicker@...gle.com>, kernel-team@...roid.com,
linux-kernel@...r.kernel.org, devicetree@...r.kernel.org,
linux-gpio@...r.kernel.org, linux-hardening@...r.kernel.org
Subject: Re: [PATCH v2 5/6] gpio: max77759: add Maxim MAX77759 gpio driver
On Fri, 2025-02-28 at 10:58 +0000, André Draszik wrote:
> Hi Linus,
>
> Thanks for you review!
>
> On Fri, 2025-02-28 at 08:10 +0100, Linus Walleij wrote:
> > Hi André,
> >
> > thanks for your patch!
> >
> > mostly looks fine, given the MFD design is accepted.
> > Nitpicks below:
> >
> > On Wed, Feb 26, 2025 at 6:51 PM André Draszik <andre.draszik@...aro.org> wrote:
> >
> > > +static irqreturn_t max77759_gpio_irqhandler(int irq, void *data)
> > > +{
> > > + int handled = 0;
> >
> > bool handled = false;
> >
> > (...)
> > > + for_each_set_bit(offset, &pending, MAX77759_N_GPIOS) {
> > > + unsigned int virq;
> >
> > I usually just call this "irq", as it's not any more virtual than any other
> > Linux magic number, and it can confuse people working with
> > actual virtualization when we call things virtual like this.
>
> Calling it 'irq' would shadow the first argument of this irq
> handler function, which is also and usually called irq and which
> I'd like to avoid shadowing.
>
> Are you OK with 'subirq'? Or any other preference?
Actually, there's no real need for that variable, I'll just
drop it altogether:
handle_nested_irq(irq_find_mapping(gc->irq.domain,
offset));
A.
Powered by blists - more mailing lists