[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250304091804.GG3713119@black.fi.intel.com>
Date: Tue, 4 Mar 2025 11:18:04 +0200
From: Mika Westerberg <mika.westerberg@...ux.intel.com>
To: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
Cc: Bartosz Golaszewski <bartosz.golaszewski@...aro.org>,
linux-gpio@...r.kernel.org, linux-acpi@...r.kernel.org,
linux-kernel@...r.kernel.org, Mika Westerberg <westeri@...nel.org>,
Linus Walleij <linus.walleij@...aro.org>,
Bartosz Golaszewski <brgl@...ev.pl>,
Kent Gibson <warthog618@...il.com>
Subject: Re: [PATCH v1 2/3] gpiolib: Rename gpio_set_debounce_timeout() to
gpiod_do_set_debounce()
On Mon, Mar 03, 2025 at 06:00:33PM +0200, Andy Shevchenko wrote:
> In order to reduce the 'gpio' namespace when operate over GPIO descriptor
> rename gpio_set_debounce_timeout() to gpiod_do_set_debounce().
To me anything that has '_do_' in their name sounds like an internal static
function that gets wrapped by the actual API function(s).
For instance it could be
int gpio_set_debounce_timeout()
{
...
gpiod_do_set_debounce()
...
However, gpiod_set_debounce_timeout() or gpiod_set_debounce() sounds good
to me.
Powered by blists - more mailing lists