[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <Z8bMDi1TIlCaec2X@pc636>
Date: Tue, 4 Mar 2025 10:46:54 +0100
From: Uladzislau Rezki <urezki@...il.com>
To: Liu Ye <liuye@...inos.cn>
Cc: akpm@...ux-foundation.org, urezki@...il.com, hch@...radead.org,
linux-mm@...ck.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] mm/vmalloc: Move free_vm_area(area) from the
__vmalloc_area_node function to the __vmalloc_node_range_noprof function
On Mon, Mar 03, 2025 at 09:57:02AM +0800, Liu Ye wrote:
> Moved free_vm_area from the __vmalloc_area_node function to the
> __vmalloc_node_range_noprof function so that allocation and freeing
> of the area can be paired in one function for better readability.
>
> Signed-off-by: Liu Ye <liuye@...inos.cn>
> ---
> mm/vmalloc.c | 5 +++--
> 1 file changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/mm/vmalloc.c b/mm/vmalloc.c
> index a6e7acebe9ad..dc658d4af181 100644
> --- a/mm/vmalloc.c
> +++ b/mm/vmalloc.c
> @@ -3651,7 +3651,6 @@ static void *__vmalloc_area_node(struct vm_struct *area, gfp_t gfp_mask,
> warn_alloc(gfp_mask, NULL,
> "vmalloc error: size %lu, failed to allocated page array size %lu",
> nr_small_pages * PAGE_SIZE, array_size);
> - free_vm_area(area);
> return NULL;
> }
>
> @@ -3844,8 +3843,10 @@ void *__vmalloc_node_range_noprof(unsigned long size, unsigned long align,
>
> /* Allocate physical pages and map them into vmalloc space. */
> ret = __vmalloc_area_node(area, gfp_mask, prot, shift, node);
> - if (!ret)
> + if (!ret) {
> + free_vm_area(area);
> goto fail;
> + }
>
> /*
> * Mark the pages as accessible, now that they are mapped.
> --
> 2.25.1
>
This one looks good to me:
Reviewed-by: Uladzislau Rezki (Sony) <urezki@...il.com>
--
Uladzislau Rezki
Powered by blists - more mailing lists