[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <061301db8d27$02e0ced0$08a26c70$@samsung.com>
Date: Tue, 4 Mar 2025 22:30:58 +0530
From: "Shradha Todi" <shradha.t@...sung.com>
To: 'Krzysztof Wilczyński' <kw@...ux.com>, "'Manivannan
Sadhasivam'" <manivannan.sadhasivam@...aro.org>
Cc: <linux-kernel@...r.kernel.org>, <linux-pci@...r.kernel.org>,
<linux-arm-kernel@...ts.infradead.org>, <linux-perf-users@...r.kernel.org>,
<lpieralisi@...nel.org>, <robh@...nel.org>, <bhelgaas@...gle.com>,
<jingoohan1@...il.com>, <Jonathan.Cameron@...wei.com>, <fan.ni@...sung.com>,
<nifan.cxl@...il.com>, <a.manzanares@...sung.com>,
<pankaj.dubey@...sung.com>, <cassel@...nel.org>, <18255117159@....com>,
<xueshuai@...ux.alibaba.com>, <renyu.zj@...ux.alibaba.com>,
<will@...nel.org>, <mark.rutland@....com>
Subject: RE: [PATCH v7 4/5] Add debugfs based error injection support in DWC
> -----Original Message-----
> From: Krzysztof Wilczyński <kw@...ux.com>
> Sent: 04 March 2025 21:05
> To: Manivannan Sadhasivam <manivannan.sadhasivam@...aro.org>
> Cc: Shradha Todi <shradha.t@...sung.com>; linux-kernel@...r.kernel.org; linux-pci@...r.kernel.org; linux-arm-
> kernel@...ts.infradead.org; linux-perf-users@...r.kernel.org; lpieralisi@...nel.org; robh@...nel.org; bhelgaas@...gle.com;
> jingoohan1@...il.com; Jonathan.Cameron@...wei.com; fan.ni@...sung.com; nifan.cxl@...il.com;
> a.manzanares@...sung.com; pankaj.dubey@...sung.com; cassel@...nel.org; 18255117159@....com;
> xueshuai@...ux.alibaba.com; renyu.zj@...ux.alibaba.com; will@...nel.org; mark.rutland@....com
> Subject: Re: [PATCH v7 4/5] Add debugfs based error injection support in DWC
>
> Hello,
>
> [....]
> > > > + 29) Generates duplicate TLPs - duplicate_dllp
> > > > + 30) Generates Nullified TLPs - nullified_tlp
> > >
> > > Would the above field called "duplicate_dllp" for duplicate TLPs be
> > > a potential typo? Perhaps this should be called "duplicate_tlp"?
> > >
> >
> > Looks like a typo. As per Synopsys documentation, there is only 'duplicate TLP'
> > field.
> >
> > Good catch!
>
> Updated. Thank you!
>
Sorry, this was a typo. Krzysztof, we need another change for this typo.
diff --git a/drivers/pci/controller/dwc/pcie-designware-debugfs.c b/drivers/pci/controller/dwc/pcie-designware-debugfs.c
index 729ac14ff700..4d77db3ca6ae 100644
--- a/drivers/pci/controller/dwc/pcie-designware-debugfs.c
+++ b/drivers/pci/controller/dwc/pcie-designware-debugfs.c
@@ -113,7 +113,7 @@ static const struct dwc_pcie_err_inj err_inj_list[] = {
{"posted_tlp_data", 0x4, 0x4},
{"non_post_tlp_data", 0x4, 0x5},
{"cmpl_tlp_data", 0x4, 0x6},
- {"duplicate_dllp", 0x5, 0x0},
+ {"duplicate_tlp", 0x5, 0x0},
{"nullified_tlp", 0x5, 0x1},
};
So sorry for the inconvenience! Should I post a patch for this?
> Krzysztof
Powered by blists - more mailing lists