[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <174117659047.2914008.10640330234349833814@ping.linuxembedded.co.uk>
Date: Wed, 05 Mar 2025 12:09:50 +0000
From: Kieran Bingham <kieran.bingham@...asonboard.com>
To: Tarang Raval <tarang.raval@...iconsignals.io>, shravan kumar <Shravan.Chippa@...rochip.com>
Cc: Mauro Carvalho Chehab <mchehab@...nel.org>, linux-media@...r.kernel.org <linux-media@...r.kernel.org>, linux-kernel@...r.kernel.org <linux-kernel@...r.kernel.org>, Conor Dooley <conor.dooley@...rochip.com>, Valentina.FernandezAlanis@...rochip.com <valentina.fernandezalanis@...rochip.com>, Praveen.Kumar@...rochip.com <praveen.kumar@...rochip.com>, Sakari Ailus <sakari.ailus@...ux.intel.com>
Subject: Re: [PATCH V7 4/4] media: i2c: imx334: add modes for 720p and 480p resolutions
Quoting Tarang Raval (2025-03-05 11:30:57)
> > Quoting Tarang Raval (2025-03-05 10:40:18)
> > > Hi Kieran, Shravan
> > >
> > > > > -----Original Message-----
> > > > > From: Kieran Bingham <kieran.bingham@...asonboard.com>
> > > > > Sent: Wednesday, March 5, 2025 3:05 PM
> > > > > To: mchehab@...nel.org; sakari.ailus@...ux.intel.com; shravan Chippa -
> > > > > I35088 <Shravan.Chippa@...rochip.com>
> > > > > Cc: linux-media@...r.kernel.org; linux-kernel@...r.kernel.org; Conor Dooley
> > > > > - M52691 <Conor.Dooley@...rochip.com>; Valentina Fernandez Alanis -
> > > > > M63239 <Valentina.FernandezAlanis@...rochip.com>; Praveen Kumar -
> > > > > I30718 <Praveen.Kumar@...rochip.com>; shravan Chippa - I35088
> > > > > <Shravan.Chippa@...rochip.com>
> > > > > Subject: Re: [PATCH V7 4/4] media: i2c: imx334: add modes for 720p and 480p
> > > > > resolutions
> > > > >
> > > > > EXTERNAL EMAIL: Do not click links or open attachments unless you know the
> > > > > content is safe
> > > > >
> > > > > Quoting shravan kumar (2025-03-05 05:14:42)
> > > > > > From: Shravan Chippa <shravan.chippa@...rochip.com>
> > > > > >
> > > > > > Added support for 1280x720@30 and 640x480@30 resolutions
> > > > > >
> > > > > > Signed-off-by: Shravan Chippa <shravan.chippa@...rochip.com>
> > > > > > ---
> > > > > >� drivers/media/i2c/imx334.c | 66
> > > > > > ++++++++++++++++++++++++++++++++++++++
> > > > > >� 1 file changed, 66 insertions(+)
> > > > > >
> > > > > > diff --git a/drivers/media/i2c/imx334.c b/drivers/media/i2c/imx334.c
> > > > > > index a7c0bd38c9b8..8cd1eecd0143 100644
> > > > > > --- a/drivers/media/i2c/imx334.c
> > > > > > +++ b/drivers/media/i2c/imx334.c
> > > > > > @@ -314,6 +314,46 @@ static const struct imx334_reg
> > > > > > common_mode_regs[] = {
> > > > > >�������� {0x3002, 0x00},
> > > > > >� };
> > > > > >
> > > > > > +/* Sensor mode registers for 640x480@...ps */ static const struct
> > > > > > +imx334_reg mode_640x480_regs[] = {
> > > > > > +������ {0x302c, 0x70},
> > > > > > +������ {0x302d, 0x06},
> > > > >
> > > > > These two are a single 16 bit register HTRIMMING_START = 1648
> > > > >
> > > > > > +������ {0x302e, 0x80},
> > > > > > +������ {0x302f, 0x02},
> > > > >
> > > > > These two are a single 16 bit register HNUM = 640
> > > > >
> > > > > > +������ {0x3074, 0x48},
> > > > > > +������ {0x3075, 0x07},
> > > > >
> > > > > These two are a single 16 bit (well, 12 bit value) AREA3_ST_ADR_1 = 1864
> > > > >
> > > > > > +������ {0x308e, 0x49},
> > > > > > +������ {0x308f, 0x07},
> > > > >
> > > > > These two are a single 16 bit register AREA3_ST_ADR_2 = 1865
> > > > >
> > > > > > +������ {0x3076, 0xe0},
> > > > > > +������ {0x3077, 0x01},
> > > > >
> > > > > These two are a single 16 bit register AREA3_WIDTH_1 = 480
> > > > >
> > > > > > +������ {0x3090, 0xe0},
> > > > > > +������ {0x3091, 0x01},
> > > > >
> > > > > These two are a single 16 bit register AREA3_WIDTH_2 = 480
> > > > >
> > > > > > +������ {0x3308, 0xe0},
> > > > > > +������ {0x3309, 0x01},
> > > > >
> > > > > These two are a single 16 bit register Y_OUT_SIZE
> > > > >
> > > > > Don't you think
> > > > >�������� { Y_OUT_SIZE, 480 },
> > > > >
> > > > > Is so much more readable and easier to comprehend and maintain?
> > > > >
> > > > >
> > > > > > +������ {0x30d8, 0x30},
> > > > > > +������ {0x30d9, 0x0b},
> > > > >
> > > > > These two are a single 16 bit register UNREAD_ED_ADR = 2864
> > > > >
> > > > > > +};
> > > > >
> > > > > I'm still sad that we can all know the names of all these registers and yet this
> > > > > is writing new tables of hex values.
> > > >
> > > > Do you want me use call like bellow API with register names:
> > > > CCI_REG16_LE(0x30d8);
> > > > cci_write();
> > > > cci_multi_reg_write();
> > > > devm_cci_regmap_init_i2c();
> > >
> > > I have made a patch series for this sensor driver's improvement, in which
> > > I added the V4L2 CCI helper.
> > >
> >
> > Has it been posted yet ?
>
> Not yet.
>
> As mentioned below, I am waiting for this patch series to be applied.
>
> Best Regards,
> Tarang
>
> > > I am just waiting for this patch series to be applied so I can send my
> > > changes on top of it.
> >
> > If the conversion will happen after I'm fine with that - but it will
> > need to be tested by someone with the hardware. Changing to CCI regs can
> > have impacts that are hard to catch unless you really check and re-test
> > the driver - so Shravan is best placed if he is actively working on the
> > sensor.
> >
> > Personally - I would like to see the CCI conversion happen *first* and
> > then Shravan's changes go on top of that ! It would be /far/ more
> > reviewable and readable that way.
> >
> > (And we'd have more confidence that Shravan will have tested the full
> > CCI implementation on that version).
Well, knowing that there is already work in place to improve the
readability of the driver - I'm fine seeing these patches merged first -
Shravan - will you be able to test Tarang's work on top ?
--
Kieran
> >
> > --
> > Kieran
Powered by blists - more mailing lists