[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250310-unique-ref-v6-0-1ff53558617e@pm.me>
Date: Mon, 10 Mar 2025 08:49:36 +0000
From: Oliver Mangold <oliver.mangold@...me>
To: Miguel Ojeda <ojeda@...nel.org>, Alex Gaynor <alex.gaynor@...il.com>, Boqun Feng <boqun.feng@...il.com>, Gary Guo <gary@...yguo.net>, Björn Roy Baron <bjorn3_gh@...tonmail.com>, Benno Lossin <benno.lossin@...ton.me>, Andreas Hindborg <a.hindborg@...nel.org>, Alice Ryhl <aliceryhl@...gle.com>, Trevor Gross <tmgross@...ch.edu>, Asahi Lina <lina@...hilina.net>
Cc: rust-for-linux@...r.kernel.org, linux-kernel@...r.kernel.org, Oliver Mangold <oliver.mangold@...me>
Subject: [PATCH v6 0/5] New trait OwnableRefCounted for ARef<->Owned conversion.
This allows to convert between ARef<T> and Owned<T> by
implementing the new trait OwnedRefCounted.
This way we will have a shared/unique reference counting scheme
for types with built-in refcounts in analogy to Arc/UniqueArc.
Signed-off-by: Oliver Mangold <oliver.mangold@...me>
---
Changes in v6:
- Changed comments/formatting as suggested by Miguel Ojeda
- Included and used new config flag RUSTC_HAS_DO_NOT_RECOMMEND,
thus no changes to types.rs will be needed when the attribute
becomes available.
- Fixed commit message for Owned patch.
- Link to v5: https://lore.kernel.org/r/20250307-unique-ref-v5-0-bffeb633277e@pm.me
Changes in v5:
- Rebase the whole thing on top of the Ownable/Owned traits by Asahi Lina.
- Rename AlwaysRefCounted to RefCounted and make AlwaysRefCounted a
marker trait instead to allow to obtain an ARef<T> from an &T,
which (as Alice pointed out) is unsound when combined with UniqueRef/Owned.
- Change the Trait design and naming to implement this feature,
UniqueRef/UniqueRefCounted is dropped in favor of Ownable/Owned and
OwnableRefCounted is used to provide the functions to convert
between Owned and ARef.
- Link to v4: https://lore.kernel.org/r/20250305-unique-ref-v4-1-a8fdef7b1c2c@pm.me
Changes in v4:
- Just a minor change in naming by request from Andreas Hindborg,
try_shared_to_unique() -> try_from_shared(),
unique_to_shared() -> into_shared(),
which is more in line with standard Rust naming conventions.
- Link to v3: https://lore.kernel.org/r/Z8Wuud2UQX6Yukyr@mango
---
Asahi Lina (1):
rust: types: Add Ownable/Owned types
Miguel Ojeda (1):
rust: kbuild: provide `RUSTC_HAS_DO_NOT_RECOMMEND` symbol
Oliver Mangold (3):
rust: make Owned::into_raw() and Owned::from_raw() public
rust: rename AlwaysRefCounted to RefCounted
rust: adding OwnableRefCounted and SimpleOwnableRefCounted
init/Kconfig | 3 +
rust/kernel/block/mq/request.rs | 10 +-
rust/kernel/cred.rs | 8 +-
rust/kernel/device.rs | 8 +-
rust/kernel/fs/file.rs | 10 +-
rust/kernel/pid_namespace.rs | 8 +-
rust/kernel/task.rs | 6 +-
rust/kernel/types.rs | 429 ++++++++++++++++++++++++++++++++++++++--
8 files changed, 451 insertions(+), 31 deletions(-)
---
base-commit: 4b2ee22fe32ea9b255926effbb6f26450607c391
change-id: 20250305-unique-ref-29fcd675f9e9
Best regards,
--
Oliver Mangold <oliver.mangold@...me>
Powered by blists - more mailing lists