[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250311111310.495922-2-thorsten.blum@linux.dev>
Date: Tue, 11 Mar 2025 12:13:11 +0100
From: Thorsten Blum <thorsten.blum@...ux.dev>
To: Kent Overstreet <kent.overstreet@...ux.dev>
Cc: Thorsten Blum <thorsten.blum@...ux.dev>,
linux-bcachefs@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: [PATCH] bcachefs: Use max() to improve gen_after()
Use max() to simplify gen_after() and improve its readability.
Signed-off-by: Thorsten Blum <thorsten.blum@...ux.dev>
---
fs/bcachefs/buckets.h | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/fs/bcachefs/buckets.h b/fs/bcachefs/buckets.h
index a9acdd6c0c86..124ac380b22e 100644
--- a/fs/bcachefs/buckets.h
+++ b/fs/bcachefs/buckets.h
@@ -167,9 +167,7 @@ static inline int gen_cmp(u8 a, u8 b)
static inline int gen_after(u8 a, u8 b)
{
- int r = gen_cmp(a, b);
-
- return r > 0 ? r : 0;
+ return max(0, gen_cmp(a, b));
}
static inline int dev_ptr_stale_rcu(struct bch_dev *ca, const struct bch_extent_ptr *ptr)
--
2.48.1
Powered by blists - more mailing lists