[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250317155349.1236188-6-lkml@antheas.dev>
Date: Mon, 17 Mar 2025 16:53:41 +0100
From: Antheas Kapenekakis <lkml@...heas.dev>
To: platform-driver-x86@...r.kernel.org
Cc: linux-hwmon@...r.kernel.org,
linux-doc@...r.kernel.org,
linux-pm@...r.kernel.org,
Guenter Roeck <linux@...ck-us.net>,
Jean Delvare <jdelvare@...e.com>,
Jonathan Corbet <corbet@....net>,
Joaquin Ignacio Aramendia <samsagax@...il.com>,
Derek J Clark <derekjohn.clark@...il.com>,
Kevin Greenberg <kdgreenberg234@...tonmail.com>,
Joshua Tam <csinaction@...me>,
Parth Menon <parthasarathymenon@...il.com>,
Eileen <eileen@...-netbook.com>,
linux-kernel@...r.kernel.org,
sre@...nel.org,
linux@...ssschuh.net,
Antheas Kapenekakis <lkml@...heas.dev>
Subject: [PATCH v5 05/13] platform/x86: oxpec: Rename ec group to tt_toggle
Currently, the EC group is used for the turbo button. However, the next
patch in the series adds support for the LED button in X1 devices, which
is only applicable for X1 devices. Therefore, rename it to prepare for
adding the second group.
Reviewed-by: Derek J. Clark <derekjohn.clark@...il.com>
Signed-off-by: Antheas Kapenekakis <lkml@...heas.dev>
---
drivers/platform/x86/oxpec.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/platform/x86/oxpec.c b/drivers/platform/x86/oxpec.c
index dc3a0871809cd..8836b3df0d57e 100644
--- a/drivers/platform/x86/oxpec.c
+++ b/drivers/platform/x86/oxpec.c
@@ -681,18 +681,18 @@ static const struct hwmon_channel_info * const oxp_platform_sensors[] = {
NULL,
};
-static struct attribute *oxp_ec_attrs[] = {
+static struct attribute *oxp_tt_toggle_attrs[] = {
&dev_attr_tt_toggle.attr,
NULL
};
-static struct attribute_group oxp_ec_attribute_group = {
+static struct attribute_group oxp_tt_toggle_attribute_group = {
.is_visible = tt_toggle_is_visible,
- .attrs = oxp_ec_attrs,
+ .attrs = oxp_tt_toggle_attrs,
};
static const struct attribute_group *oxp_ec_groups[] = {
- &oxp_ec_attribute_group,
+ &oxp_tt_toggle_attribute_group,
NULL
};
--
2.48.1
Powered by blists - more mailing lists