[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1c7018f1-fdc5-4fc6-adc7-fae592851710@redhat.com>
Date: Mon, 17 Mar 2025 09:56:47 +0100
From: David Hildenbrand <david@...hat.com>
To: Liu Ye <liuyerd@....com>, akpm@...ux-foundation.org
Cc: willy@...radead.org, ran.xiaokai@....com.cn, dan.carpenter@...aro.org,
linux-kernel@...r.kernel.org, linux-fsdevel@...r.kernel.org,
Liu Ye <liuye@...inos.cn>
Subject: Re: [PATCH] fs/proc/page: Refactoring to reduce code duplication.
On 17.03.25 09:01, Liu Ye wrote:
> From: Liu Ye <liuye@...inos.cn>
>
> The function kpageflags_read and kpagecgroup_read is quite similar
> to kpagecount_read. Consider refactoring common code into a helper
> function to reduce code duplication.
>
> Signed-off-by: Liu Ye <liuye@...inos.cn>
> ---
> fs/proc/page.c | 158 ++++++++++++++++---------------------------------
> 1 file changed, 50 insertions(+), 108 deletions(-)
>
> diff --git a/fs/proc/page.c b/fs/proc/page.c
> index a55f5acefa97..f413016ebe67 100644
> --- a/fs/proc/page.c
> +++ b/fs/proc/page.c
> @@ -37,19 +37,17 @@ static inline unsigned long get_max_dump_pfn(void)
> #endif
> }
>
> -/* /proc/kpagecount - an array exposing page mapcounts
> - *
> - * Each entry is a u64 representing the corresponding
> - * physical page mapcount.
> - */
> -static ssize_t kpagecount_read(struct file *file, char __user *buf,
> - size_t count, loff_t *ppos)
> +static ssize_t kpage_read(struct file *file, char __user *buf,
> + size_t count, loff_t *ppos,
> + u64 (*get_page_info)(struct page *))
Can we just indicate using an enum which operation to perform, so we can
avoid having+passing these functions?
--
Cheers,
David / dhildenb
Powered by blists - more mailing lists