[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <89e743e5-7ff6-43fe-bd52-97f0ca6ab07e@linaro.org>
Date: Tue, 18 Mar 2025 16:05:10 +0100
From: neil.armstrong@...aro.org
To: Nitin Rawat <quic_nitirawa@...cinc.com>, vkoul@...nel.org,
kishon@...nel.org, manivannan.sadhasivam@...aro.org,
James.Bottomley@...senPartnership.com, martin.petersen@...cle.com,
konrad.dybcio@....qualcomm.com
Cc: quic_rdwivedi@...cinc.com, linux-arm-msm@...r.kernel.org,
linux-phy@...ts.infradead.org, linux-kernel@...r.kernel.org,
linux-scsi@...r.kernel.org
Subject: Re: [PATCH V2 1/6] phy: qcom-qmp-ufs: Rename qmp_ufs_enable and
qmp_ufs_power_on
On 18/03/2025 15:49, Nitin Rawat wrote:
> Rename qmp_ufs_enable to qmp_ufs_power_on and qmp_ufs_power_on to
> qmp_ufs_phy_calibrate to better reflect functionality. Also
> update function calls and structure assignments accordingly.
>
> Co-developed-by: Ram Kumar Dwivedi <quic_rdwivedi@...cinc.com>
> Signed-off-by: Ram Kumar Dwivedi <quic_rdwivedi@...cinc.com>
> Signed-off-by: Nitin Rawat <quic_nitirawa@...cinc.com>
> ---
> drivers/phy/qualcomm/phy-qcom-qmp-ufs.c | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c b/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c
> index 45b3b792696e..bb836bc0f736 100644
> --- a/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c
> +++ b/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c
> @@ -1837,7 +1837,7 @@ static int qmp_ufs_init(struct phy *phy)
> return 0;
> }
>
> -static int qmp_ufs_power_on(struct phy *phy)
> +static int qmp_ufs_phy_calibrate(struct phy *phy)
> {
> struct qmp_ufs *qmp = phy_get_drvdata(phy);
> const struct qmp_phy_cfg *cfg = qmp->cfg;
> @@ -1898,7 +1898,7 @@ static int qmp_ufs_exit(struct phy *phy)
> return 0;
> }
>
> -static int qmp_ufs_enable(struct phy *phy)
> +static int qmp_ufs_power_on(struct phy *phy)
> {
> int ret;
>
> @@ -1906,7 +1906,7 @@ static int qmp_ufs_enable(struct phy *phy)
> if (ret)
> return ret;
>
> - ret = qmp_ufs_power_on(phy);
> + ret = qmp_ufs_phy_calibrate(phy);
> if (ret)
> qmp_ufs_exit(phy);
>
> @@ -1940,7 +1940,7 @@ static int qmp_ufs_set_mode(struct phy *phy, enum phy_mode mode, int submode)
> }
>
> static const struct phy_ops qcom_qmp_ufs_phy_ops = {
> - .power_on = qmp_ufs_enable,
> + .power_on = qmp_ufs_power_on,
> .power_off = qmp_ufs_disable,
> .set_mode = qmp_ufs_set_mode,
> .owner = THIS_MODULE,
> --
> 2.48.1
>
>
Reviewed-by: Neil Armstrong <neil.armstrong@...aro.org>
Powered by blists - more mailing lists