[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <fd023be2-a265-4641-b5b4-d26f25cc85b8@gmail.com>
Date: Thu, 20 Mar 2025 08:12:12 +0200
From: Matti Vaittinen <mazziesaccount@...il.com>
To: Simon Horman <horms@...nel.org>
Cc: Matti Vaittinen <matti.vaittinen@...rohmeurope.com>,
Jonathan Cameron <jic23@...nel.org>, Lars-Peter Clausen <lars@...afoo.de>,
Rob Herring <robh@...nel.org>,
Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
Daniel Scally <djrscally@...il.com>,
Heikki Krogerus <heikki.krogerus@...ux.intel.com>,
Sakari Ailus <sakari.ailus@...ux.intel.com>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
"Rafael J. Wysocki" <rafael@...nel.org>, Danilo Krummrich <dakr@...nel.org>,
Claudiu Manoil <claudiu.manoil@....com>, Andrew Lunn
<andrew+netdev@...n.ch>, "David S. Miller" <davem@...emloft.net>,
Eric Dumazet <edumazet@...gle.com>, Jakub Kicinski <kuba@...nel.org>,
Paolo Abeni <pabeni@...hat.com>, linux-acpi@...r.kernel.org,
linux-kernel@...r.kernel.org, netdev@...r.kernel.org
Subject: Re: [PATCH net-next v8 09/10] net: gianfar: Use
device_get_child_node_count_named()
On 19/03/2025 18:07, Simon Horman wrote:
> On Mon, Mar 17, 2025 at 05:52:25PM +0200, Matti Vaittinen wrote:
>> We can avoid open-coding the loop construct which counts firmware child
>> nodes with a specific name by using the newly added
>> device_get_child_node_count_named().
>>
>> The gianfar driver has such open-coded loop. Replace it with the
>> device_get_child_node_count_named().
>>
>> Suggested-by: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
>> Signed-off-by: Matti Vaittinen <mazziesaccount@...il.com>
>> Reviewed-by: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
>
> This patch looks good to me.
> But I think it would be best to resubmit it,
> as a standalone patch for net-next, once
> it's dependencies are present in net-next.
Thanks Simon. I think you're right.
Powered by blists - more mailing lists