[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <Z9vxcPCw8tDsjKw1@OneApple>
Date: Thu, 20 Mar 2025 18:44:00 +0800
From: Taotao Chen <chentaotao@...iglobal.com>
To: <sj@...nel.org>
CC: <akpm@...ux-foundation.org>, <linux-kernel@...r.kernel.org>
Subject: [PATCH] mm/damon/core: simplify control flow in damon_register_ops()
The function logic is not complex, so using goto is unnecessary.
Replace it with a straightforward if-else to simplify control flow
and improve readability.
Signed-off-by: Taotao Chen <chentaotao@...iglobal.com>
---
mm/damon/core.c | 9 ++++-----
1 file changed, 4 insertions(+), 5 deletions(-)
diff --git a/mm/damon/core.c b/mm/damon/core.c
index 384935ef4e65..a3bdc09d38fe 100644
--- a/mm/damon/core.c
+++ b/mm/damon/core.c
@@ -76,14 +76,13 @@ int damon_register_ops(struct damon_operations *ops)
if (ops->id >= NR_DAMON_OPS)
return -EINVAL;
+
mutex_lock(&damon_ops_lock);
/* Fail for already registered ops */
- if (__damon_is_registered_ops(ops->id)) {
+ if (__damon_is_registered_ops(ops->id))
err = -EINVAL;
- goto out;
- }
- damon_registered_ops[ops->id] = *ops;
-out:
+ else
+ damon_registered_ops[ops->id] = *ops;
mutex_unlock(&damon_ops_lock);
return err;
}
--
2.34.1
Powered by blists - more mailing lists