lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <2025032045-rack-abreast-5055@gregkh>
Date: Thu, 20 Mar 2025 07:12:05 -0700
From: Greg Kroah-Hartman <gregkh@...uxfoundation.org>
To: Gabriel Lima Luz <lima.gabriel.luz@...il.com>
Cc: linux-fbdev@...r.kernel.org, linux-staging@...ts.linux.dev,
	linux-kernel@...r.kernel.org,
	Sudip Mukherjee <sudipm.mukherjee@...il.com>,
	Teddy Wang <teddy.wang@...iconmotion.com>,
	~lkcamp/patches@...ts.sr.ht
Subject: Re: [PATCH v2] staging: sm750fb: Remove unused enum dpms

On Fri, Mar 14, 2025 at 02:31:09PM -0300, Gabriel Lima Luz wrote:
> remove unused enum and replace its usage with
> a unsigned int.
> add comment to ddk750_set_dpms function for
> documenting state values
> 
> Signed-off-by: Gabriel Lima Luz <lima.gabriel.luz@...il.com>
> ---
>  drivers/staging/sm750fb/ddk750_power.c | 10 ++++++++--
>  drivers/staging/sm750fb/ddk750_power.h |  9 +--------
>  2 files changed, 9 insertions(+), 10 deletions(-)
> 
> diff --git a/drivers/staging/sm750fb/ddk750_power.c b/drivers/staging/sm750fb/ddk750_power.c
> index 12834f78eef7..547a96ccba9b 100644
> --- a/drivers/staging/sm750fb/ddk750_power.c
> +++ b/drivers/staging/sm750fb/ddk750_power.c
> @@ -3,8 +3,14 @@
>  #include "ddk750_reg.h"
>  #include "ddk750_power.h"
>  
> -void ddk750_set_dpms(enum dpms state)
> -{
> +void ddk750_set_dpms(unsigned int state)
> +{	/*
> +	 *	state values documentation
> +	 *	crt_DPMS_ON = 0x0,
> +	 *	crt_DPMS_STANDBY = 0x1,
> +	 *	crt_DPMS_SUSPEND = 0x2,
> +	 *	crt_DPMS_OFF = 0x3,	unsigned int value;
> +	 */
>  	unsigned int value;

Why not just make this "enum dpms" instead?

thanks,

greg k-h

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ