[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <923e7fa7-6476-4140-bf49-3e4e67419479@oracle.com>
Date: Fri, 21 Mar 2025 12:23:10 -0400
From: Sidhartha Kumar <sidhartha.kumar@...cle.com>
To: Ye Liu <ye.liu@...ux.dev>, akpm@...ux-foundation.org
Cc: linux-mm@...ck.org, linux-kernel@...r.kernel.org,
Ye Liu <liuye@...inos.cn>
Subject: Re: [PATCH v2] mm/page_alloc: Consolidate unlikely handling in
page_expected_state
On 3/21/25 2:20 AM, Ye Liu wrote:
> From: Ye Liu <liuye@...inos.cn>
>
> This patch consolidates the handling of unlikely conditions in the
> page_expected_state function, reducing code duplication and improving
> readability.
>
> Previously, the check_new_page_bad function contained logic to handle
> __PG_HWPOISON flags, which was called from check_new_page. This patch
> moves the handling of __PG_HWPOISON flags into the page_expected_state
> function and removes the check_new_page_bad function. The check_new_page
> function now directly calls bad_page if the page has unexpected flags.
>
> This change simplifies the code by reducing the number of functions and
> centralizing the unlikely condition handling in one place.
>
> Signed-off-by: Ye Liu <liuye@...inos.cn>
>
> ---
> V2: return true instead of false in the PageHWPoison branch.
> ---
> ---
> mm/page_alloc.c | 24 ++++++++----------------
> 1 file changed, 8 insertions(+), 16 deletions(-)
>
> diff --git a/mm/page_alloc.c b/mm/page_alloc.c
> index 2842da893eea..e8b95c6a96c2 100644
> --- a/mm/page_alloc.c
> +++ b/mm/page_alloc.c
> @@ -903,6 +903,12 @@ static inline bool page_expected_state(struct page *page,
> (page->flags & check_flags)))
> return false;
>
> + if (unlikely(PageHWPoison(page))) {
> + /* Don't complain about hwpoisoned pages */
> + if (PageBuddy(page))
> + __ClearPageBuddy(page);
> + }
> +
> return true;
> }
>
> @@ -1586,29 +1592,15 @@ static __always_inline void page_del_and_expand(struct zone *zone,
> account_freepages(zone, -nr_pages, migratetype);
> }
>
> -static void check_new_page_bad(struct page *page)
> -{
> - if (unlikely(PageHWPoison(page))) {
> - /* Don't complain about hwpoisoned pages */
> - if (PageBuddy(page))
> - __ClearPageBuddy(page);
> - return;
> - }
> -
> - bad_page(page,
> - page_bad_reason(page, PAGE_FLAGS_CHECK_AT_PREP));
> -}
> -
> /*
> * This page is about to be returned from the page allocator
> */
> static bool check_new_page(struct page *page)
> {
> - if (likely(page_expected_state(page,
> - PAGE_FLAGS_CHECK_AT_PREP|__PG_HWPOISON)))
> + if (likely(page_expected_state(page, PAGE_FLAGS_CHECK_AT_PREP)))
> return false;
>
> - check_new_page_bad(page);
> + bad_page(page, page_bad_reason(page, PAGE_FLAGS_CHECK_AT_PREP));
> return true;
> }
>
Reviewed-by: Sidhartha Kumar <sidhartha.kumar@...cle.com>
Powered by blists - more mailing lists