[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20250324151551.76869d80@kernel.org>
Date: Mon, 24 Mar 2025 15:15:51 -0700
From: Jakub Kicinski <kuba@...nel.org>
To: Michael Klein <michael@...sekall.de>
Cc: Andrew Lunn <andrew@...n.ch>, Heiner Kallweit <hkallweit1@...il.com>,
Russell King <linux@...linux.org.uk>, "David S. Miller"
<davem@...emloft.net>, Eric Dumazet <edumazet@...gle.com>, Paolo Abeni
<pabeni@...hat.com>, netdev@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [net-next v4 1/3] net: phy: realtek: Clean up RTL8211E ExtPage
access
Sorry for the delay, unfortunately this no longer applies:
Applying: net: phy: realtek: Clean up RTL8211E ExtPage access
error: patch failed: drivers/net/phy/realtek/realtek_main.c:28
error: drivers/net/phy/realtek/realtek_main.c: patch does not apply
Patch failed at 0001 net: phy: realtek: Clean up RTL8211E ExtPage access
hint: Use 'git am --show-current-patch=diff' to see the failed patch
hint: When you have resolved this problem, run "git am --continue".
hint: If you prefer to skip this patch, run "git am --skip" instead.
hint: To restore the original branch and stop patching, run "git am --abort".
hint: Disable this message with "git config set advice.mergeConflict false"
Given that some nits before you send v5 below..
On Mon, 17 Mar 2025 21:05:30 +0100 Michael Klein wrote:
> - Factor out RTL8211E extension page access code to
> rtl8211e_modify_ext_page()/rtl8211e_read_ext_page() and add some
> related #define:s
> - Group RTL8211E_* and RTL8211F_* #define:s
> - Clean up rtl8211e_config_init()
Sounds like this should be split into at least 2 patches.
> static int rtl821x_probe(struct phy_device *phydev)
> {
> struct device *dev = &phydev->mdio.dev;
> @@ -600,7 +617,8 @@ static int rtl8211f_led_hw_control_set(struct phy_device *phydev, u8 index,
>
> static int rtl8211e_config_init(struct phy_device *phydev)
> {
> - int ret = 0, oldpage;
> + const u16 delay_mask = RTL8211E_CTRL_DELAY |
> + RTL8211E_TX_DELAY | RTL8211E_RX_DELAY;
This would probably be easier to read if alinged.
const u16 delay_mask = RTL8211E_CTRL_DELAY |
RTL8211E_TX_DELAY |
RTL8211E_RX_DELAY;
--
pw-bot: cr
Powered by blists - more mailing lists