[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAJaqyWdtKEYiY2tBB0F477LqxVs8fzaix96551WSMa=KdT3C5Q@mail.gmail.com>
Date: Wed, 26 Mar 2025 07:39:47 +0100
From: Eugenio Perez Martin <eperezma@...hat.com>
To: Lei Yang <leiyang@...hat.com>
Cc: Jason Wang <jasowang@...hat.com>, mst@...hat.com, xuanzhuo@...ux.alibaba.com,
virtualization@...ts.linux.dev, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 00/19] virtio_ring in order support
On Mon, Mar 24, 2025 at 3:44 PM Lei Yang <leiyang@...hat.com> wrote:
>
> QE tested this series of patches with virtio-net regression tests,
> everything works fine.
>
Hi Lei,
Is it possible to test this series also with virtio-net-pci,...,in_order=on?
Thanks!
> Tested-by: Lei Yang <leiyang@...hat.com>
>
> On Mon, Mar 24, 2025 at 1:45 PM Jason Wang <jasowang@...hat.com> wrote:
> >
> > Hello all:
> >
> > This sereis tries to implement the VIRTIO_F_IN_ORDER to
> > virtio_ring. This is done by introducing virtqueue ops so we can
> > implement separate helpers for different virtqueue layout/features
> > then the in-order were implmeented on top.
> >
> > Tests shows 5% imporvemnt in RX PPS with KVM guest + testpmd on the
> > host.
> >
> > Please review.
> >
> > Thanks
> >
> > Jason Wang (19):
> > virtio_ring: rename virtqueue_reinit_xxx to virtqueue_reset_xxx()
> > virtio_ring: switch to use vring_virtqueue in virtqueue_poll variants
> > virtio_ring: unify logic of virtqueue_poll() and more_used()
> > virtio_ring: switch to use vring_virtqueue for virtqueue resize
> > variants
> > virtio_ring: switch to use vring_virtqueue for virtqueue_kick_prepare
> > variants
> > virtio_ring: switch to use vring_virtqueue for virtqueue_add variants
> > virtio: switch to use vring_virtqueue for virtqueue_add variants
> > virtio_ring: switch to use vring_virtqueue for enable_cb_prepare
> > variants
> > virtio_ring: use vring_virtqueue for enable_cb_delayed variants
> > virtio_ring: switch to use vring_virtqueue for disable_cb variants
> > virtio_ring: switch to use vring_virtqueue for detach_unused_buf
> > variants
> > virtio_ring: use u16 for last_used_idx in virtqueue_poll_split()
> > virtio_ring: introduce virtqueue ops
> > virtio_ring: determine descriptor flags at one time
> > virtio_ring: factor out core logic of buffer detaching
> > virtio_ring: factor out core logic for updating last_used_idx
> > virtio_ring: move next_avail_idx to vring_virtqueue
> > virtio_ring: factor out split indirect detaching logic
> > virtio_ring: add in order support
> >
> > drivers/virtio/virtio_ring.c | 856 ++++++++++++++++++++++++++---------
> > 1 file changed, 653 insertions(+), 203 deletions(-)
> >
> > --
> > 2.42.0
> >
> >
>
Powered by blists - more mailing lists