[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <87zfh86rqi.fsf@intel.com>
Date: Wed, 26 Mar 2025 11:55:33 +0200
From: Jani Nikula <jani.nikula@...ux.intel.com>
To: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
dri-devel@...ts.freedesktop.org, linux-kernel@...r.kernel.org
Cc: Oded Gabbay <ogabbay@...nel.org>, "Avizrat, Yaron"
<yaron.avizrat@...el.com>, "Elbaz, Koby" <koby.elbaz@...el.com>, "Sinyuk,
Konstantin" <konstantin.sinyuk@...el.com>
Subject: Re: [PATCH v3 1/1] accel/habanalabs: Switch to use %ptTs
On Wed, 26 Mar 2025, Andy Shevchenko <andriy.shevchenko@...ux.intel.com> wrote:
> +Cc: Jani (sorry, forgot to add you in the first place).
>
> Do you think it's applicable now?
Cc: Yaron, Koby, and Konstantin who are supposed to be the new
maintainers for accel/habanalabs.
BR,
Jani.
>
> On Wed, Mar 05, 2025 at 01:00:25PM +0200, Andy Shevchenko wrote:
>> Use %ptTs instead of open-coded variant to print contents of time64_t type
>> in human readable form.
>>
>> This changes N/A output to 1970-01-01 00:00:00 for zero timestamps,
>> but it's used only in the dev_err() output and won't break anything.
>>
>> Signed-off-by: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
>> ---
>>
>> v3: explained the difference for N/A cases (Jani)
>> v2: fixed the parameters to be the pointers
>>
>> drivers/accel/habanalabs/common/device.c | 25 +++---------------------
>> 1 file changed, 3 insertions(+), 22 deletions(-)
>>
>> diff --git a/drivers/accel/habanalabs/common/device.c b/drivers/accel/habanalabs/common/device.c
>> index 68eebed3b050..80fa08bf57bd 100644
>> --- a/drivers/accel/habanalabs/common/device.c
>> +++ b/drivers/accel/habanalabs/common/device.c
>> @@ -1066,28 +1066,11 @@ static bool is_pci_link_healthy(struct hl_device *hdev)
>> return (device_id == hdev->pdev->device);
>> }
>>
>> -static void stringify_time_of_last_heartbeat(struct hl_device *hdev, char *time_str, size_t size,
>> - bool is_pq_hb)
>> -{
>> - time64_t seconds = is_pq_hb ? hdev->heartbeat_debug_info.last_pq_heartbeat_ts
>> - : hdev->heartbeat_debug_info.last_eq_heartbeat_ts;
>> - struct tm tm;
>> -
>> - if (!seconds)
>> - return;
>> -
>> - time64_to_tm(seconds, 0, &tm);
>> -
>> - snprintf(time_str, size, "%ld-%02d-%02d %02d:%02d:%02d (UTC)",
>> - tm.tm_year + 1900, tm.tm_mon, tm.tm_mday, tm.tm_hour, tm.tm_min, tm.tm_sec);
>> -}
>> -
>> static bool hl_device_eq_heartbeat_received(struct hl_device *hdev)
>> {
>> struct eq_heartbeat_debug_info *heartbeat_debug_info = &hdev->heartbeat_debug_info;
>> u32 cpu_q_id = heartbeat_debug_info->cpu_queue_id, pq_pi_mask = (HL_QUEUE_LENGTH << 1) - 1;
>> struct asic_fixed_properties *prop = &hdev->asic_prop;
>> - char pq_time_str[64] = "N/A", eq_time_str[64] = "N/A";
>>
>> if (!prop->cpucp_info.eq_health_check_supported)
>> return true;
>> @@ -1095,17 +1078,15 @@ static bool hl_device_eq_heartbeat_received(struct hl_device *hdev)
>> if (!hdev->eq_heartbeat_received) {
>> dev_err(hdev->dev, "EQ heartbeat event was not received!\n");
>>
>> - stringify_time_of_last_heartbeat(hdev, pq_time_str, sizeof(pq_time_str), true);
>> - stringify_time_of_last_heartbeat(hdev, eq_time_str, sizeof(eq_time_str), false);
>> dev_err(hdev->dev,
>> - "EQ: {CI %u, HB counter %u, last HB time: %s}, PQ: {PI: %u, CI: %u (%u), last HB time: %s}\n",
>> + "EQ: {CI %u, HB counter %u, last HB time: %ptTs}, PQ: {PI: %u, CI: %u (%u), last HB time: %ptTs}\n",
>> hdev->event_queue.ci,
>> heartbeat_debug_info->heartbeat_event_counter,
>> - eq_time_str,
>> + &hdev->heartbeat_debug_info.last_eq_heartbeat_ts,
>> hdev->kernel_queues[cpu_q_id].pi,
>> atomic_read(&hdev->kernel_queues[cpu_q_id].ci),
>> atomic_read(&hdev->kernel_queues[cpu_q_id].ci) & pq_pi_mask,
>> - pq_time_str);
>> + &hdev->heartbeat_debug_info.last_pq_heartbeat_ts);
>>
>> hl_eq_dump(hdev, &hdev->event_queue);
>>
>> --
>> 2.47.2
>>
--
Jani Nikula, Intel
Powered by blists - more mailing lists