lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <8734ey10dp.wl-kuninori.morimoto.gx@renesas.com>
Date: Fri, 28 Mar 2025 00:09:54 +0000
From: Kuninori Morimoto <kuninori.morimoto.gx@...esas.com>
To: Prabhakar <prabhakar.csengg@...il.com>
Cc: Geert Uytterhoeven <geert+renesas@...der.be>,
	Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
	Yoshihiro Shimoda <yoshihiro.shimoda.uh@...esas.com>,
	linux-usb@...r.kernel.org,
	linux-renesas-soc@...r.kernel.org,
	linux-kernel@...r.kernel.org,
	Biju Das <biju.das.jz@...renesas.com>,
	Claudiu Beznea <claudiu.beznea.uj@...renesas.com>,
	Fabrizio Castro <fabrizio.castro.jz@...esas.com>,
	Lad Prabhakar <prabhakar.mahadev-lad.rj@...renesas.com>
Subject: Re: [PATCH 1/3] usb: renesas_usbhs: Correct function reference in comment


Hi Prabhakar

Thank you for your patch

> From: Lad Prabhakar <prabhakar.mahadev-lad.rj@...renesas.com>
> 
> Update the comment to reference `usbhs_mod_probe` instead of
> `usbhs_mod_init`, as `usbhs_mod_probe` is the correct function
> used in this context.
> 
> Signed-off-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@...renesas.com>
> ---
>  drivers/usb/renesas_usbhs/common.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/usb/renesas_usbhs/common.c b/drivers/usb/renesas_usbhs/common.c
> index 4b35ef216125..15ef246a1245 100644
> --- a/drivers/usb/renesas_usbhs/common.c
> +++ b/drivers/usb/renesas_usbhs/common.c
> @@ -698,7 +698,7 @@ static int usbhs_probe(struct platform_device *pdev)
>  	if (ret < 0)
>  		goto probe_end_fifo_exit;
>  
> -	/* dev_set_drvdata should be called after usbhs_mod_init */
> +	/* dev_set_drvdata should be called after usbhs_mod_probe */
>  	platform_set_drvdata(pdev, priv);

If you want to care about context, it seems we want to care "dev_set_drvdata"
and "platform_set_drvdata" too :)
And, it is easy to understand that it indicates function if it has ().
like below

-	/* dev_set_drvdata should be called after usbhs_mod_init */
+	/* platform_set_drvdata() should be called after usbhs_mod_probe() */
	platform_set_drvdata(pdev, priv);

Thank you for your help !!

Best regards
---
Kuninori Morimoto

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ