[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20250328114443.GA597674@robin.jannau.net>
Date: Fri, 28 Mar 2025 12:44:43 +0100
From: Janne Grunau <j@...nau.net>
To: shao.mingyin@....com.cn
Cc: fnkl.kernel@...il.com, dri-devel@...ts.freedesktop.org,
asahi@...ts.linux.dev, linux-kernel@...r.kernel.org,
yang.yang29@....com.cn, xu.xin16@....com.cn, ye.xingchen@....com.cn,
tang.dongxing@....com.cn
Subject: Re: [PATCH] drm: adp: Use device_match_of_node()
On Fri, Mar 28, 2025 at 05:07:05PM +0800, shao.mingyin@....com.cn wrote:
> From: Tang Dongxing <tang.dongxing@....com.cn>
>
> Replace the open-code with device_match_of_node().
>
> Signed-off-by: Tang Dongxing <tang.dongxing@....com.cn>
> Signed-off-by: Shao Mingyin <shao.mingyin@....com.cn>
> ---
> drivers/gpu/drm/adp/adp_drv.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/adp/adp_drv.c b/drivers/gpu/drm/adp/adp_drv.c
> index c98c647f981d..0abb56ce2c34 100644
> --- a/drivers/gpu/drm/adp/adp_drv.c
> +++ b/drivers/gpu/drm/adp/adp_drv.c
> @@ -553,7 +553,7 @@ static const struct component_master_ops adp_master_ops = {
>
> static int compare_dev(struct device *dev, void *data)
> {
> - return dev->of_node == data;
> + return device_match_of_node(dev, data);
> }
please remove compare_dev() completely and replace the argmunent in the
drm_of_component_match_add() call directly. Commonly
component_compare_of() is used but it is also just a wrapper around
device_match_of_node().
drivers/gpu/drm/arm/hdlcd_drv.c and drivers/gpu/drm/arm/malidp_drv.c
follow the same pattern so please fix those as well. One of them was
used as template for this driver.
Thanks,
Janne
Powered by blists - more mailing lists