[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250331071409.ycI7q6Q2@linutronix.de>
Date: Mon, 31 Mar 2025 09:14:09 +0200
From: Sebastian Sewior <bigeasy@...utronix.de>
To: Alexei Starovoitov <alexei.starovoitov@...il.com>
Cc: Linus Torvalds <torvalds@...ux-foundation.org>,
bpf <bpf@...r.kernel.org>, Daniel Borkmann <daniel@...earbox.net>,
Andrii Nakryiko <andrii@...nel.org>,
Martin KaFai Lau <martin.lau@...nel.org>,
Andrew Morton <akpm@...ux-foundation.org>,
Peter Zijlstra <peterz@...radead.org>,
Vlastimil Babka <vbabka@...e.cz>,
Steven Rostedt <rostedt@...dmis.org>,
Michal Hocko <mhocko@...e.com>,
Shakeel Butt <shakeel.butt@...ux.dev>,
linux-mm <linux-mm@...ck.org>, LKML <linux-kernel@...r.kernel.org>
Subject: Re: [GIT PULL] Introduce try_alloc_pages for 6.15
On 2025-03-30 14:49:25 [-0700], Alexei Starovoitov wrote:
> On Sun, Mar 30, 2025 at 1:56 PM Linus Torvalds
> <torvalds@...ux-foundation.org> wrote:
> > So maybe "nmisafe_local_lock_t" or something in that vein?
> >
> > Please fix this up, There aren't *that* many users of
> > "localtry_xyzzy", let's get this fixed before there are more of them.
>
> Ok. Agree with the reasoning that the name doesn't quite fit.
>
> nmisafe_local_lock_t name works for me,
> though nmisafe_local_lock_irqsave() is a bit verbose.
>
> Don't have better name suggestions at the moment.
>
> Sebastian, Vlastimil,
> what do you prefer ?
nmisafe_local_lock_t sounds okay assuming the "nmisafe" part does not
make it look like it can be used without the trylock part in NMI context.
But yeah, it sounds better than the previous one.
Sebastian
Powered by blists - more mailing lists