[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <012377fd-e292-42fc-b348-4bb5e5becb97@intel.com>
Date: Mon, 31 Mar 2025 09:15:36 -0700
From: Reinette Chatre <reinette.chatre@...el.com>
To: Tony Luck <tony.luck@...el.com>, Fenghua Yu <fenghuay@...dia.com>, "Maciej
Wieczor-Retman" <maciej.wieczor-retman@...el.com>, Peter Newman
<peternewman@...gle.com>, James Morse <james.morse@....com>, Babu Moger
<babu.moger@....com>, Drew Fustini <dfustini@...libre.com>, Dave Martin
<Dave.Martin@....com>
CC: <linux-kernel@...r.kernel.org>, <patches@...ts.linux.dev>
Subject: Re: [PATCH v2 04/16] x86/resctrl: Change generic monitor functions to
use struct rdt_domain_hdr
Hi Tony,
On 3/21/25 4:15 PM, Tony Luck wrote:
> Functions that don't need the internal details of the rdt_mon_domain
> can operate on just the rdt_domain_hdr.
This does not seem accurate. The functions are modified to take rdt_domain_hdr
as parameter but then the functions are modified to extract rdt_mon_domain
based on rdt_domain_hdr .... and proceeds to operate on internals of
rdt_mon_domain in a way that contradicts the changelog.
Considering what comes later this seems risky to me to rely on the
code flow to interpret which structure rdt_domain_hdr forms part of. I think
that it will be safer if rdt_domain_hdr gets an identifier that reflects which
structure it forms part of so that the accessors could be made explicit and
have error checking.
Reinette
Powered by blists - more mailing lists