[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <bb8442f9-4c43-4195-a0a8-4e7023a10880@intel.com>
Date: Tue, 1 Apr 2025 10:16:24 -0700
From: "Chang S. Bae" <chang.seok.bae@...el.com>
To: Chao Gao <chao.gao@...el.com>, <x86@...nel.org>,
<linux-kernel@...r.kernel.org>, <kvm@...r.kernel.org>, <tglx@...utronix.de>,
<dave.hansen@...el.com>, <seanjc@...gle.com>, <pbonzini@...hat.com>
CC: <peterz@...radead.org>, <rick.p.edgecombe@...el.com>,
<weijiang.yang@...el.com>, <john.allen@....com>, <bp@...en8.de>,
<xin3.li@...el.com>, Ingo Molnar <mingo@...hat.com>, Dave Hansen
<dave.hansen@...ux.intel.com>, "H. Peter Anvin" <hpa@...or.com>, "Maxim
Levitsky" <mlevitsk@...hat.com>, Samuel Holland <samuel.holland@...ive.com>,
Mitchell Levy <levymitchell0@...il.com>, Li RongQing <lirongqing@...du.com>,
Vignesh Balasubramanian <vigbalas@....com>, Aruna Ramakrishna
<aruna.ramakrishna@...cle.com>
Subject: Re: [PATCH v4 7/8] x86/fpu/xstate: Introduce "guest-only" supervisor
xfeature set
On 3/18/2025 8:31 AM, Chao Gao wrote:
>
> Dropped Dave's Suggested-by as the patch has been changed significantly
I think you should provide a clear argument outlining the considerable
naming options and their trade-offs.
I noticed you referenced Thomas’s feedback in the cover letter (it would
be clearer to elaborate here rather than using just the above one-liner):
> Rename XFEATURE_MASK_KERNEL_DYNAMIC to XFEATURE_MASK_SUPERVISOR_GUEST
> as tglx noted "this dynamic naming is really bad":
>
> https://lore.kernel.org/all/87sg1owmth.ffs@nanos.tec.linutronix.de/
While Thomas objected to the "dynamic" naming, have you fully considered
why he found it problematic? Likewise, have you re-evaluated Dave’s
original suggestion and his intent? Rather than just quoting feedback,
you should summarize the key concerns, analyze the pros and cons of
different naming approaches, and clearly justify your final choice.
Thanks,
Chang
Powered by blists - more mailing lists