[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAD_4BXiaHEndVCKYOHnA9=CcZ7jRFzFEs_+A=09duhzuf2X9+w@mail.gmail.com>
Date: Thu, 3 Apr 2025 14:06:45 -0700
From: William Kennington <william@...nnington.com>
To: Guenter Roeck <linux@...ck-us.net>
Cc: Jean Delvare <jdelvare@...e.com>, linux-hwmon@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] hwmon: (pmbus): Introduce page_change_delay
On Wed, Apr 2, 2025 at 3:18 PM Guenter Roeck <linux@...ck-us.net> wrote:
>
> On 4/2/25 12:34, William A. Kennington III wrote:
> > We have some buggy pmbus devices that require a delay after performing a
> > page change operation before trying to issue more commands to the
> > device.
> >
> > This allows for a configurable delay after page changes, but not
> > affecting other read or write operations.
> >
> > Signed-off-by: William A. Kennington III <william@...nnington.com>
> > ---
> > drivers/hwmon/pmbus/pmbus.h | 1 +
> > drivers/hwmon/pmbus/pmbus_core.c | 59 ++++++++++++++++++++++----------
> > 2 files changed, 41 insertions(+), 19 deletions(-)
> >
> > diff --git a/drivers/hwmon/pmbus/pmbus.h b/drivers/hwmon/pmbus/pmbus.h
> > index ddb19c9726d6..742dafc44390 100644
> > --- a/drivers/hwmon/pmbus/pmbus.h
> > +++ b/drivers/hwmon/pmbus/pmbus.h
> > @@ -482,6 +482,7 @@ struct pmbus_driver_info {
> > */
> > int access_delay; /* in microseconds */
> > int write_delay; /* in microseconds */
> > + int page_change_delay; /* in microseconds */
> > };
> >
> > /* Regulator ops */
> > diff --git a/drivers/hwmon/pmbus/pmbus_core.c b/drivers/hwmon/pmbus/pmbus_core.c
> > index 787683e83db6..cfb724a8718b 100644
> > --- a/drivers/hwmon/pmbus/pmbus_core.c
> > +++ b/drivers/hwmon/pmbus/pmbus_core.c
> > @@ -116,6 +116,7 @@ struct pmbus_data {
> > int vout_high[PMBUS_PAGES]; /* voltage high margin */
> > ktime_t write_time; /* Last SMBUS write timestamp */
> > ktime_t access_time; /* Last SMBUS access timestamp */
> > + ktime_t page_change_time; /* Last SMBUS page change timestamp */
> > };
> >
> > struct pmbus_debugfs_entry {
> > @@ -178,24 +179,44 @@ static void pmbus_wait(struct i2c_client *client)
> >
> > if (delta < info->access_delay)
> > fsleep(info->access_delay - delta);
> > - } else if (info->write_delay) {
> > + }
> > + if (info->write_delay) {
> > delta = ktime_us_delta(ktime_get(), data->write_time);
> >
> > if (delta < info->write_delay)
> > fsleep(info->write_delay - delta);
> > }
> > + if (info->page_change_delay) {
> > + delta = ktime_us_delta(ktime_get(), data->page_change_time);
> > +
>
> page_change_time isn't actually set. I suggest to just use data->write_time.
> Also see below.
Yeah, I consolidated the times in v2 and will keep it in v3
>
> > + if (delta < info->page_change_delay)
> > + fsleep(info->page_change_delay - delta);
> > + }
> > }
> >
> > -/* Sets the last accessed timestamp for pmbus_wait */
> > -static void pmbus_update_ts(struct i2c_client *client, bool write_op)
> > +#define PMBUS_OP_READ_BIT 1
> > +#define PMBUS_OP_WRITE_BIT 2
> > +#define PMBUS_OP_PAGE_CHANGE_BIT 4
>
> #define<space>NAME<tab>BIT(...)
>
> > +
> > +#define PMBUS_OP_READ PMBUS_OP_READ_BIT
> > +#define PMBUS_OP_WRITE PMBUS_OP_WRITE_BIT
> > +#define PMBUS_OP_PAGE_CHANGE (PMBUS_OP_PAGE_CHANGE_BIT | PMBUS_OP_WRITE)
>
> That is way too complicated. Just make it
>
> #define PMBUS_OP_READ BIT(0)
> #define PMBUS_OP_WRITE BIT(1)
> #define PMBUS_OP_PAGE_CHANGE BIT(2)
>
> A page change implies a write, so it is not necessary to combine the bits.
Yeah, I combined then here to make the function working with the
delays consider both delays. I'll make this simpler.
>
> > +
> > +/* Sets the last operation timestamp for pmbus_wait */
> > +static void pmbus_update_ts(struct i2c_client *client, int op)
> > {
> > struct pmbus_data *data = i2c_get_clientdata(client);
> > const struct pmbus_driver_info *info = data->info;
> > + ktime_t now = ktime_get();
> >
> > if (info->access_delay) {
> > - data->access_time = ktime_get();
> > - } else if (info->write_delay && write_op) {
> > - data->write_time = ktime_get();
> > + data->access_time = now;
> > + }
> > + if (info->write_delay && (op & PMBUS_OP_WRITE_BIT)) {
> > + data->write_time = now;
> > + }
> > + if (info->page_change_delay && (op & PMBUS_OP_PAGE_CHANGE_BIT)) {
> > + data->write_time = now;
> > }
>
> Seems to me that we should only need write_time and not
> page_change_time since both will always be set together.
>
> I also think this can be simplified if ktime_get() is always called anyway.
>
> ktime_t now = ktime_get();
>
> data->access_time = now;
> if (op & (PMBUS_OP_WRITE | PMBUS_OP_PAGE_CHANGE))
> data->write_time = now;
>
> It doesn't matter if the values are set unnecessarily if there is no delay
> because they won't be used in that case.
Yes, I think v2 (and shortly v3) makes this better
>
> > }
> >
> > @@ -211,13 +232,13 @@ int pmbus_set_page(struct i2c_client *client, int page, int phase)
> > data->info->pages > 1 && page != data->currpage) {
> > pmbus_wait(client);
> > rv = i2c_smbus_write_byte_data(client, PMBUS_PAGE, page);
> > - pmbus_update_ts(client, true);
> > + pmbus_update_ts(client, PMBUS_OP_PAGE_CHANGE);
> > if (rv < 0)
> > return rv;
> >
> > pmbus_wait(client);
> > rv = i2c_smbus_read_byte_data(client, PMBUS_PAGE);
> > - pmbus_update_ts(client, false);
> > + pmbus_update_ts(client, PMBUS_OP_READ);
> > if (rv < 0)
> > return rv;
> >
> > @@ -231,7 +252,7 @@ int pmbus_set_page(struct i2c_client *client, int page, int phase)
> > pmbus_wait(client);
> > rv = i2c_smbus_write_byte_data(client, PMBUS_PHASE,
> > phase);
> > - pmbus_update_ts(client, true);
> > + pmbus_update_ts(client, PMBUS_OP_WRITE);
> > if (rv)
> > return rv;
> > }
> > @@ -251,7 +272,7 @@ int pmbus_write_byte(struct i2c_client *client, int page, u8 value)
> >
> > pmbus_wait(client);
> > rv = i2c_smbus_write_byte(client, value);
> > - pmbus_update_ts(client, true);
> > + pmbus_update_ts(client, PMBUS_OP_WRITE);
> >
> > return rv;
> > }
> > @@ -286,7 +307,7 @@ int pmbus_write_word_data(struct i2c_client *client, int page, u8 reg,
> >
> > pmbus_wait(client);
> > rv = i2c_smbus_write_word_data(client, reg, word);
> > - pmbus_update_ts(client, true);
> > + pmbus_update_ts(client, PMBUS_OP_WRITE);
> >
> > return rv;
> > }
> > @@ -408,7 +429,7 @@ int pmbus_read_word_data(struct i2c_client *client, int page, int phase, u8 reg)
> >
> > pmbus_wait(client);
> > rv = i2c_smbus_read_word_data(client, reg);
> > - pmbus_update_ts(client, false);
> > + pmbus_update_ts(client, PMBUS_OP_READ);
> >
> > return rv;
> > }
> > @@ -471,7 +492,7 @@ int pmbus_read_byte_data(struct i2c_client *client, int page, u8 reg)
> >
> > pmbus_wait(client);
> > rv = i2c_smbus_read_byte_data(client, reg);
> > - pmbus_update_ts(client, false);
> > + pmbus_update_ts(client, PMBUS_OP_READ);
> >
> > return rv;
> > }
> > @@ -487,7 +508,7 @@ int pmbus_write_byte_data(struct i2c_client *client, int page, u8 reg, u8 value)
> >
> > pmbus_wait(client);
> > rv = i2c_smbus_write_byte_data(client, reg, value);
> > - pmbus_update_ts(client, true);
> > + pmbus_update_ts(client, PMBUS_OP_WRITE);
> >
> > return rv;
> > }
> > @@ -523,7 +544,7 @@ static int pmbus_read_block_data(struct i2c_client *client, int page, u8 reg,
> >
> > pmbus_wait(client);
> > rv = i2c_smbus_read_block_data(client, reg, data_buf);
> > - pmbus_update_ts(client, false);
> > + pmbus_update_ts(client, PMBUS_OP_READ);
> >
> > return rv;
> > }
> > @@ -2530,7 +2551,7 @@ static int pmbus_read_coefficients(struct i2c_client *client,
> > rv = i2c_smbus_xfer(client->adapter, client->addr, client->flags,
> > I2C_SMBUS_WRITE, PMBUS_COEFFICIENTS,
> > I2C_SMBUS_BLOCK_PROC_CALL, &data);
> > - pmbus_update_ts(client, true);
> > + pmbus_update_ts(client, PMBUS_OP_READ | PMBUS_OP_WRITE);
>
> I don't immediately follow the reason for adding PMBUS_OP_READ.
I can just remove it, I just added it for clarity as opposed to having
it just be 0.
>
> >
> > if (rv < 0)
> > return rv;
> > @@ -2734,7 +2755,7 @@ static int pmbus_init_common(struct i2c_client *client, struct pmbus_data *data,
> > if (!(data->flags & PMBUS_NO_CAPABILITY)) {
> > pmbus_wait(client);
> > ret = i2c_smbus_read_byte_data(client, PMBUS_CAPABILITY);
> > - pmbus_update_ts(client, false);
> > + pmbus_update_ts(client, PMBUS_OP_READ);
> >
> > if (ret >= 0 && (ret & PB_CAPABILITY_ERROR_CHECK)) {
> > if (i2c_check_functionality(client->adapter, I2C_FUNC_SMBUS_PEC))
> > @@ -2750,13 +2771,13 @@ static int pmbus_init_common(struct i2c_client *client, struct pmbus_data *data,
> > data->read_status = pmbus_read_status_word;
> > pmbus_wait(client);
> > ret = i2c_smbus_read_word_data(client, PMBUS_STATUS_WORD);
> > - pmbus_update_ts(client, false);
> > + pmbus_update_ts(client, PMBUS_OP_READ);
> >
> > if (ret < 0 || ret == 0xffff) {
> > data->read_status = pmbus_read_status_byte;
> > pmbus_wait(client);
> > ret = i2c_smbus_read_byte_data(client, PMBUS_STATUS_BYTE);
> > - pmbus_update_ts(client, false);
> > + pmbus_update_ts(client, PMBUS_OP_READ);
> >
> > if (ret < 0 || ret == 0xff) {
> > dev_err(dev, "PMBus status register not found\n");
>
Powered by blists - more mailing lists