[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ynp7rzrlqj26pgimogurymwmn2tpeg5knofowant2g3dvagows@5r3n4sy4buf2>
Date: Wed, 2 Apr 2025 17:34:42 -0700
From: Josh Poimboeuf <jpoimboe@...nel.org>
To: Ingo Molnar <mingo@...nel.org>
Cc: x86@...nel.org, linux-kernel@...r.kernel.org, amit@...nel.org,
kvm@...r.kernel.org, amit.shah@....com, thomas.lendacky@....com, bp@...en8.de,
tglx@...utronix.de, peterz@...radead.org, pawan.kumar.gupta@...ux.intel.com,
corbet@....net, mingo@...hat.com, dave.hansen@...ux.intel.com, hpa@...or.com,
seanjc@...gle.com, pbonzini@...hat.com, daniel.sneddon@...ux.intel.com,
kai.huang@...el.com, sandipan.das@....com, boris.ostrovsky@...cle.com,
Babu.Moger@....com, david.kaplan@....com, dwmw@...zon.co.uk,
andrew.cooper3@...rix.com
Subject: Re: [PATCH v3 1/6] x86/bugs: Rename entry_ibpb()
On Wed, Apr 02, 2025 at 09:37:07PM +0200, Ingo Molnar wrote:
>
> * Josh Poimboeuf <jpoimboe@...nel.org> wrote:
>
> > There's nothing entry-specific about entry_ibpb(). In preparation for
> > calling it from elsewhere, rename it to __write_ibpb().
>
> Minor Git-log hygienic request, could you please mention in such
> patches what the *new* name is?
>
> This title is annoyingly passive-aggressive:
LOL
> x86/bugs: Rename entry_ibpb()
>
> Let's make it:
>
> x86/bugs: Rename entry_ibpb() to write_ibpb()
>
> ... or so. Because the new name is infinitely more important going
> forward than the old name is ever going to be. :-)
Indeed, thanks.
--
Josh
Powered by blists - more mailing lists