[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Z-57GF_DWR8D-AZG@smile.fi.intel.com>
Date: Thu, 3 Apr 2025 15:12:08 +0300
From: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To: Bartosz Golaszewski <brgl@...ev.pl>
Cc: Mika Westerberg <mika.westerberg@...ux.intel.com>,
Bartosz Golaszewski <bartosz.golaszewski@...aro.org>,
linux-gpio@...r.kernel.org, linux-acpi@...r.kernel.org,
linux-kernel@...r.kernel.org, Mika Westerberg <westeri@...nel.org>,
Linus Walleij <linus.walleij@...aro.org>
Subject: Re: [PATCH v1 4/5] gpiolib: acpi: Reuse struct acpi_gpio_params in
struct acpi_gpio_lookup
On Thu, Apr 03, 2025 at 01:57:22PM +0200, Bartosz Golaszewski wrote:
> On Thu, Apr 3, 2025 at 1:04 PM Andy Shevchenko
> <andriy.shevchenko@...ux.intel.com> wrote:
> > On Thu, Apr 03, 2025 at 01:35:06PM +0300, Mika Westerberg wrote:
> > > On Wed, Apr 02, 2025 at 03:21:19PM +0300, Andy Shevchenko wrote:
> > > > Some of the contents of struct acpi_gpio_lookup repeats what we have
> > > > in the struct acpi_gpio_params. Reuse the latter in the former.
> >
> > > > + struct acpi_gpio_params par;
> > >
> > > params is better name
> >
> > It's been already used elsewhere in the code. Do you want renaming there as
> > well for consistency's sake?
>
> +1 for using param or params here and elsewhere. It's much better than par.
Okay, will be an add-on in the next version. But I will wait for Mika and
others to review the rest and give tags and/or comments where it applies.
--
With Best Regards,
Andy Shevchenko
Powered by blists - more mailing lists