lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <65e8ed9d-0fff-4f70-b095-8df52493ebec@suse.com>
Date: Thu, 3 Apr 2025 16:08:39 +0300
From: Nikolay Borisov <nik.borisov@...e.com>
To: Ingo Molnar <mingo@...nel.org>, linux-kernel@...r.kernel.org
Cc: Juergen Gross <jgross@...e.com>, "H . Peter Anvin" <hpa@...or.com>,
 Linus Torvalds <torvalds@...ux-foundation.org>,
 Peter Zijlstra <peterz@...radead.org>, Borislav Petkov <bp@...en8.de>,
 Thomas Gleixner <tglx@...utronix.de>
Subject: Re: [PATCH 37/49] x86/alternatives: Move text_poke_array completion
 from smp_text_poke_batch_finish() and smp_text_poke_batch_flush() to
 smp_text_poke_batch_process()



On 28.03.25 г. 15:26 ч., Ingo Molnar wrote:
> Simplifies the code and improves code generation a bit:
> 
>     text	   data	    bss	    dec	    hex	filename
>    14769	   1017	   4112	  19898	   4dba	alternative.o.before
>    14742	   1017	   4112	  19871	   4d9f	alternative.o.after
> 
> Signed-off-by: Ingo Molnar <mingo@...nel.org>
> ---
>   arch/x86/kernel/alternative.c | 11 +++++------
>   1 file changed, 5 insertions(+), 6 deletions(-)
> 
> diff --git a/arch/x86/kernel/alternative.c b/arch/x86/kernel/alternative.c
> index 1df8fac6740d..5293929488f0 100644
> --- a/arch/x86/kernel/alternative.c
> +++ b/arch/x86/kernel/alternative.c
> @@ -2750,6 +2750,9 @@ static void smp_text_poke_batch_process(void)
>   		if (unlikely(!atomic_dec_and_test(refs)))
>   			atomic_cond_read_acquire(refs, !VAL);
>   	}
> +
> +	/* They are all completed: */
> +	text_poke_array.nr_entries = 0;
>   }
>   
>   static void __smp_text_poke_batch_add(void *addr, const void *opcode, size_t len, const void *emulate)
> @@ -2857,20 +2860,16 @@ static bool text_poke_addr_ordered(void *addr)
>   
>   void smp_text_poke_batch_finish(void)
>   {
> -	if (text_poke_array.nr_entries) {
> +	if (text_poke_array.nr_entries)
>   		smp_text_poke_batch_process();
> -		text_poke_array.nr_entries = 0;
> -	}
>   }

This function becomes trivial, why not simply move the check into 
smp_text_poke_batch_process and rename it to smp_text_poke_batch_finish ?

>   
>   static void smp_text_poke_batch_flush(void *addr)
>   {
>   	lockdep_assert_held(&text_mutex);
>   
> -	if (text_poke_array.nr_entries == TP_ARRAY_NR_ENTRIES_MAX || !text_poke_addr_ordered(addr)) {
> +	if (text_poke_array.nr_entries == TP_ARRAY_NR_ENTRIES_MAX || !text_poke_addr_ordered(addr))
>   		smp_text_poke_batch_process();
> -		text_poke_array.nr_entries = 0;
> -	}
>   }
>   
>   /**


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ