[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <174404997127.31282.955160325706545600.tip-bot2@tip-bot2>
Date: Mon, 07 Apr 2025 18:19:31 -0000
From: "tip-bot2 for Andrii Nakryiko" <tip-bot2@...utronix.de>
To: linux-tip-commits@...r.kernel.org
Cc: Alexei Starovoitov <ast@...nel.org>,
Sebastian Siewior <bigeasy@...utronix.de>,
Andrii Nakryiko <andrii@...nel.org>, Ingo Molnar <mingo@...nel.org>,
Oleg Nesterov <oleg@...hat.com>, Thomas Gleixner <tglx@...utronix.de>,
Peter Zijlstra <peterz@...radead.org>, stable@...nel.org, x86@...nel.org,
linux-kernel@...r.kernel.org
Subject: [tip: perf/urgent] uprobes: Avoid false-positive lockdep splat on
CONFIG_PREEMPT_RT=y in the ri_timer() uprobe timer callback, use
raw_write_seqcount_*()
The following commit has been merged into the perf/urgent branch of tip:
Commit-ID: 0cd575cab10e114e95921321f069a08d45bc412e
Gitweb: https://git.kernel.org/tip/0cd575cab10e114e95921321f069a08d45bc412e
Author: Andrii Nakryiko <andrii@...nel.org>
AuthorDate: Fri, 04 Apr 2025 12:48:48 -07:00
Committer: Ingo Molnar <mingo@...nel.org>
CommitterDate: Mon, 07 Apr 2025 20:15:16 +02:00
uprobes: Avoid false-positive lockdep splat on CONFIG_PREEMPT_RT=y in the ri_timer() uprobe timer callback, use raw_write_seqcount_*()
Avoid a false-positive lockdep warning in the CONFIG_PREEMPT_RT=y
configuration when using write_seqcount_begin() in the uprobe timer
callback by using raw_write_* APIs.
Uprobe's use of timer callback is guaranteed to not race with itself
for a given uprobe_task, and as such seqcount's insistence on having
preemption disabled on the writer side is irrelevant. So switch to
raw_ variants of seqcount API instead of disabling preemption unnecessarily.
Also, point out in the comments more explicitly why we use seqcount
despite our reader side being rather simple and never retrying. We favor
well-maintained kernel primitive in favor of open-coding our own memory
barriers.
Fixes: 8622e45b5da1 ("uprobes: Reuse return_instances between multiple uretprobes within task")
Reported-by: Alexei Starovoitov <ast@...nel.org>
Suggested-by: Sebastian Siewior <bigeasy@...utronix.de>
Signed-off-by: Andrii Nakryiko <andrii@...nel.org>
Signed-off-by: Ingo Molnar <mingo@...nel.org>
Acked-by: Oleg Nesterov <oleg@...hat.com>
Cc: Thomas Gleixner <tglx@...utronix.de>
Cc: Peter Zijlstra <peterz@...radead.org>
Cc: stable@...nel.org
Link: https://lore.kernel.org/r/20250404194848.2109539-1-andrii@kernel.org
---
kernel/events/uprobes.c | 15 +++++++++++++--
1 file changed, 13 insertions(+), 2 deletions(-)
diff --git a/kernel/events/uprobes.c b/kernel/events/uprobes.c
index 615b4e6..8d783b5 100644
--- a/kernel/events/uprobes.c
+++ b/kernel/events/uprobes.c
@@ -1956,6 +1956,9 @@ static void free_ret_instance(struct uprobe_task *utask,
* to-be-reused return instances for future uretprobes. If ri_timer()
* happens to be running right now, though, we fallback to safety and
* just perform RCU-delated freeing of ri.
+ * Admittedly, this is a rather simple use of seqcount, but it nicely
+ * abstracts away all the necessary memory barriers, so we use
+ * a well-supported kernel primitive here.
*/
if (raw_seqcount_try_begin(&utask->ri_seqcount, seq)) {
/* immediate reuse of ri without RCU GP is OK */
@@ -2016,12 +2019,20 @@ static void ri_timer(struct timer_list *timer)
/* RCU protects return_instance from freeing. */
guard(rcu)();
- write_seqcount_begin(&utask->ri_seqcount);
+ /*
+ * See free_ret_instance() for notes on seqcount use.
+ * We also employ raw API variants to avoid lockdep false-positive
+ * warning complaining about enabled preemption. The timer can only be
+ * invoked once for a uprobe_task. Therefore there can only be one
+ * writer. The reader does not require an even sequence count to make
+ * progress, so it is OK to remain preemptible on PREEMPT_RT.
+ */
+ raw_write_seqcount_begin(&utask->ri_seqcount);
for_each_ret_instance_rcu(ri, utask->return_instances)
hprobe_expire(&ri->hprobe, false);
- write_seqcount_end(&utask->ri_seqcount);
+ raw_write_seqcount_end(&utask->ri_seqcount);
}
static struct uprobe_task *alloc_utask(void)
Powered by blists - more mailing lists