lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Z_U2YXpteKmxXriG@smile.fi.intel.com>
Date: Tue, 8 Apr 2025 17:44:49 +0300
From: Andy Shevchenko <andy@...nel.org>
To: Abraham Samuel Adekunle <abrahamadekunle50@...il.com>
Cc: outreachy@...ts.linux.dev, julia.lawall@...ia.fr,
	gregkh@...uxfoundation.org, linux-staging@...ts.linux.dev,
	linux-kernel@...r.kernel.org, david.laight.linux@...il.com,
	dan.carpenter@...aro.org
Subject: Re: [PATCH v7 1/2] staging: rtl8723bs: Add spaces and line breaks to
 improve readability

On Tue, Apr 08, 2025 at 01:31:41PM +0000, Abraham Samuel Adekunle wrote:
> The code contains no spaces around binary operators with long lines
> which reduces readability thereby not adhering to Linux kernel coding
> style.
> 
> Add white spaces around the binary operators and use line breaks to
> increase readability and ensure adherence to Linux kernel coding
> styles.

Reviewed-by: Andy Shevchenko <andy@...nel.org>
See one nit-pick below.

...

>  					} else if (SN_EQUAL(pattrib->seqnum, tx_seq)) {
> -						psta->BA_starting_seqctrl[pattrib->priority & 0x0f] = (tx_seq+1)&0xfff;
> +						psta->BA_starting_seqctrl[pattrib->priority & 0x0f] =
> +							(tx_seq + 1) & 0xfff;
>  
>  						pattrib->ampdu_en = true;/* AGG EN */
>  					} else {
> -						psta->BA_starting_seqctrl[pattrib->priority & 0x0f] = (pattrib->seqnum+1)&0xfff;
> +						psta->BA_starting_seqctrl[pattrib->priority & 0x0f] =
> +							(pattrib->seqnum + 1) & 0xfff;

Probably it deserves a blank line here as in the above case.
But it was in the original like this, so at least it not worse
than that.

>  						pattrib->ampdu_en = true;/* AGG EN */
>  					}

-- 
With Best Regards,
Andy Shevchenko



Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ