[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <cover.1744098446.git.jpoimboe@kernel.org>
Date: Tue, 8 Apr 2025 01:21:13 -0700
From: Josh Poimboeuf <jpoimboe@...nel.org>
To: x86@...nel.org
Cc: linux-kernel@...r.kernel.org,
Linus Torvalds <torvalds@...ux-foundation.org>,
Ingo Molnar <mingo@...nel.org>,
Peter Zijlstra <peterz@...radead.org>
Subject: [PATCH RFC 0/5] x86/asm: Improve code generation
Some various improvements for inline asm code generation.
The "RFC" is really patches 4 and 5, they propose a more readable format
for alternatives and objtool annotations. Bikeshedding welcome.
If a general format is agreed upon, we could do similar for other
annotations like WARN/BUG, static branches/calls, etc.
Josh Poimboeuf (5):
objtool: Remove ANNOTATE_IGNORE_ALTERNATIVE from CLAC/STAC
objtool, x86/hweight: Remove ANNOTATE_IGNORE_ALTERNATIVE
noinstr: Use asm_inline() in instrumentation_{begin,end}()
x86/alternative: Improve code generation readability
objtool: Improve code generation readability
arch/x86/include/asm/alternative.h | 88 ++++++++++++++++++--------
arch/x86/include/asm/arch_hweight.h | 6 +-
arch/x86/include/asm/smap.h | 12 ++--
include/linux/instrumentation.h | 4 +-
include/linux/objtool.h | 97 ++++++++++++++---------------
tools/objtool/check.c | 30 ++++++++-
6 files changed, 149 insertions(+), 88 deletions(-)
--
2.49.0
Powered by blists - more mailing lists