[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250409144010.GF9833@noisy.programming.kicks-ass.net>
Date: Wed, 9 Apr 2025 16:40:10 +0200
From: Peter Zijlstra <peterz@...radead.org>
To: Josh Poimboeuf <jpoimboe@...nel.org>
Cc: x86@...nel.org, linux-kernel@...r.kernel.org,
Linus Torvalds <torvalds@...ux-foundation.org>,
Ingo Molnar <mingo@...nel.org>
Subject: Re: [PATCH RFC 5/5] objtool: Improve code generation readability
On Tue, Apr 08, 2025 at 01:21:18AM -0700, Josh Poimboeuf wrote:
> Improve the readability and compactness of the objtool annotations.
> This makes it easier to see them and differentiate from other code.
>
> Before:
> -------
>
> 911:
> .pushsection .discard.annotate_insn,"M",@progbits,8
> .long 911b - .
> .long 1
> .popsection
>
> After:
> ------
>
> # <ANNOTATE_NOENDBR>
> 911: .pushsection .discard.annotate_insn,"M",@progbits,8; .long 911b - .; .long 1; .popsection
> # </ANNOTATE_NOENDBR>
Conversely, I don't mind the compact form here too much, since the only
bit that really matters is the annotation type (1, in the above case)
and that is already explicit in the marker (ANNOTATE_NOENDBR).
Powered by blists - more mailing lists