[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250410221345.ewyagu7coscpr3l7@desk>
Date: Thu, 10 Apr 2025 15:13:45 -0700
From: Pawan Gupta <pawan.kumar.gupta@...ux.intel.com>
To: Sean Christopherson <seanjc@...gle.com>
Cc: Josh Poimboeuf <jpoimboe@...nel.org>, x86@...nel.org,
Paolo Bonzini <pbonzini@...hat.com>, linux-kernel@...r.kernel.org,
kvm@...r.kernel.org
Subject: Re: [PATCH] x86/bugs/mmio: Rename mmio_stale_data_clear to
cpu_buf_vm_clear
On Thu, Apr 10, 2025 at 01:39:28PM -0700, Sean Christopherson wrote:
> On Thu, Apr 10, 2025, Pawan Gupta wrote:
> > The static key mmio_stale_data_clear controls the KVM-only mitigation for
> > MMIO Stale Data vulnerability. Rename it to reflect its purpose.
> >
> > No functional change.
> >
> > Signed-off-by: Pawan Gupta <pawan.kumar.gupta@...ux.intel.com>
> > ---
> > arch/x86/include/asm/nospec-branch.h | 2 +-
> > arch/x86/kernel/cpu/bugs.c | 16 ++++++++++------
> > arch/x86/kvm/vmx/vmx.c | 2 +-
> > 3 files changed, 12 insertions(+), 8 deletions(-)
> >
> > diff --git a/arch/x86/include/asm/nospec-branch.h b/arch/x86/include/asm/nospec-branch.h
> > index 8a5cc8e70439e10aab4eeb5b0f5e116cf635b43d..c0474e2b741737dad129159adf3b5fc056b6097c 100644
> > --- a/arch/x86/include/asm/nospec-branch.h
> > +++ b/arch/x86/include/asm/nospec-branch.h
> > @@ -561,7 +561,7 @@ DECLARE_STATIC_KEY_FALSE(mds_idle_clear);
> >
> > DECLARE_STATIC_KEY_FALSE(switch_mm_cond_l1d_flush);
> >
> > -DECLARE_STATIC_KEY_FALSE(mmio_stale_data_clear);
> > +DECLARE_STATIC_KEY_FALSE(cpu_buf_vm_clear);
>
> Could we tack on "if_mmio" or something? E.g. cpu_buf_vm_clear_if_mmio. FWIW,
> I don't love that name, so if anyone can come up with something better...
Keeping it generic has an advantage that it plays nicely with "Attack vector
controls" series:
https://lore.kernel.org/lkml/20250310164023.779191-1-david.kaplan@amd.com/
The idea being to allow mitigations to be enabled/disabled based on
user-defined threat model. MDS/TAA mitigations may be able to take
advantage this KVM-only control.
> I like the idea of tying the static key back to X86_FEATURE_CLEAR_CPU_BUF, but
> when looking at just the usage in KVM, "cpu_buf_vm_clear" doesn't provide any
> hints as to when/why KVM needs to clear buffers.
Thats fair, can we cover that with a comment like below:
---
diff --git a/arch/x86/kvm/vmx/vmx.c b/arch/x86/kvm/vmx/vmx.c
index c79720aad3df..cddad4a6eb46 100644
--- a/arch/x86/kvm/vmx/vmx.c
+++ b/arch/x86/kvm/vmx/vmx.c
@@ -7358,6 +7358,10 @@ static noinstr void vmx_vcpu_enter_exit(struct kvm_vcpu *vcpu,
* mitigation for MDS is done late in VMentry and is still
* executed in spite of L1D Flush. This is because an extra VERW
* should not matter much after the big hammer L1D Flush.
+ *
+ * cpu_buf_vm_clear is used when system is not vulnerable to MDS/TAA,
+ * but is affected by MMIO Stale Data that only needs mitigation
+ * against a rogue guest.
*/
if (static_branch_unlikely(&vmx_l1d_should_flush))
vmx_l1d_flush(vcpu);
Powered by blists - more mailing lists