lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250411-umlegen-herauf-508fe182fffa@brauner>
Date: Fri, 11 Apr 2025 16:08:13 +0200
From: Christian Brauner <brauner@...nel.org>
To: Jan Stancek <jstancek@...hat.com>
Cc: linux-fsdevel@...r.kernel.org, viro@...iv.linux.org.uk, jack@...e.cz, 
	linux-kernel@...r.kernel.org
Subject: Re: [PATCH] fs: use namespace_{lock,unlock} in dissolve_on_fput()

On Thu, Apr 10, 2025 at 05:05:42PM +0200, Jan Stancek wrote:
> In commit b73ec10a4587 ("fs: add fastpath for dissolve_on_fput()"),
> the namespace_{lock,unlock} has been replaced with scoped_guard
> using the namespace_sem. This however now also skips processing of
> 'unmounted' list in namespace_unlock(), and mount is not (immediately)
> cleaned up.

Thank you for spotting and fixing this! My bad.

> diff --git a/fs/namespace.c b/fs/namespace.c
> index 14935a0500a2..ee1fdb3baee0 100644
> --- a/fs/namespace.c
> +++ b/fs/namespace.c
> @@ -1830,6 +1830,8 @@ static inline void namespace_lock(void)
>  	down_write(&namespace_sem);
>  }
>  
> +DEFINE_GUARD(namespace_locked, struct rw_semaphore *, namespace_lock(), namespace_unlock())

I'll call that namespace_lock instead if you don't mind.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ