[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20250411170720.GD366747@cmpxchg.org>
Date: Fri, 11 Apr 2025 13:07:20 -0400
From: Johannes Weiner <hannes@...xchg.org>
To: Brendan Jackman <jackmanb@...gle.com>
Cc: Andrew Morton <akpm@...ux-foundation.org>,
Vlastimil Babka <vbabka@...e.cz>,
Mel Gorman <mgorman@...hsingularity.net>,
Carlos Song <carlos.song@....com>, linux-mm@...ck.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/2] mm: page_alloc: tighten up find_suitable_fallback()
On Fri, Apr 11, 2025 at 03:07:01PM +0000, Brendan Jackman wrote:
> On Fri Apr 11, 2025 at 1:45 PM UTC, Johannes Weiner wrote:
> >> - if (find_suitable_fallback(area, order, migratetype, true) >= 0)
> >> + if (should_try_claim_block(order, migratetype) &&
> >> + find_fallback_migratetype(area, order, migratetype) >= 0)
> >
> > So I agree with pushing the test into the callers. However, I think
> > the name "should_try_claim_block()" is not great for this. It makes
> > sense in the alloc/fallback path, but compaction here doesn't claim
> > anything. It just wants to know if this order + migratetype is
> > eligible under block claiming rules.
> >
> > IMO this would be more readable with the old terminology:
> >
> > if (can_claim_block(order, migratetype) &&
> > find_fallback_migratetype(area, order, migratetype) >= 0)
>
> Sure, that makes sense, here's a modified version of the patch:
>
> ---
>
> From 85be0fca4627c5b832a3382c92b6310609e14ca4 Mon Sep 17 00:00:00 2001
> From: Brendan Jackman <jackmanb@...gle.com>
> Date: Thu, 10 Apr 2025 13:22:58 +0000
> Subject: [PATCH] mm: page_alloc: Split up find_suitable_fallback()
>
> Now that it's been simplified, it's clear that the bool arg isn't
> needed, callers can just use should_try_claim_block(). Once that logic
> is stripped out, the function becomes very obvious and can get a more
> straightforward name and comment.
>
> Since should_try_claim_block() is now exported to compaction.c, give it
> a name that makes more sense outside the context of allocation -
> should_claim_block() seems confusing in code that has no interest in
> actually claiming a block.
>
> Signed-off-by: Brendan Jackman <jackmanb@...gle.com>
Acked-by: Johannes Weiner <hannes@...xchg.org>
Thanks!
One minor nit:
> @@ -914,8 +914,9 @@ static inline void init_cma_pageblock(struct page *page)
> #endif
>
>
> -int find_suitable_fallback(struct free_area *area, unsigned int order,
> - int migratetype, bool claimable);
> +int find_fallback_migratetype(struct free_area *area, unsigned int order,
> + int migratetype);
> +bool can_claim_block(unsigned int order, int start_mt);
Switch those around to match the C file order?
(Just being extra, and this is probably a losing battle, but hey...)
Powered by blists - more mailing lists