[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAHk-=wgCFJ923gMqPYq5YrqUuLM3He-O7wvLfpvwNrySSK0vMw@mail.gmail.com>
Date: Mon, 14 Apr 2025 09:57:16 -0700
From: Linus Torvalds <torvalds@...ux-foundation.org>
To: Ingo Molnar <mingo@...nel.org>
Cc: linux-kernel@...r.kernel.org, Thomas Gleixner <tglx@...utronix.de>,
Frederic Weisbecker <frederic@...nel.org>, "H . Peter Anvin" <hpa@...or.com>,
Peter Zijlstra <peterz@...radead.org>, Anil Gurumurthy <anil.gurumurthy@...gic.com>,
"James E.J. Bottomley" <James.Bottomley@...senpartnership.com>,
"Martin K. Petersen" <martin.petersen@...cle.com>,
Sudarsana Kalluru <sudarsana.kalluru@...gic.com>
Subject: Re: [PATCH 02/17] scsi: bfa: Rename 'timer_mod' to 'timer_module'
On Mon, 14 Apr 2025 at 03:23, Ingo Molnar <mingo@...nel.org> wrote:
>
> We'd like to introduce timer_mod() in the kernel, so make
> sure the namespace is clear.
No no, this is horribly wrong.
> - use_idlect1 = omap_dm_timer_modify_idlect_mask(use_idlect1);
> + use_idlect1 = omap_dm_timer_moduleify_idlect_mask(use_idlect1);
This was clearly all done with some completely bogus
search-and-replace, and the end result is nonsensical.
That "timer_mod" has *NOTHING* to do with a "module". It's "modify".
> -enum s3c64xx_timer_mode {
> +enum s3c64xx_timer_modulee {
Same thing. It's not "mod" as in "module" it's "mode".
> - apic->lapic_timer.timer_mode_mask = 3 << 17;
> + apic->lapic_timer.timer_modulee_mask = 3 << 17;
More nonsense.
> - return apic->lapic_timer.timer_mode == APIC_LVT_TIMER_ONESHOT;
> + return apic->lapic_timer.timer_modulee == APIC_LVT_TIMER_ONESHOT;
More nonsense.
> - ti_32k_timer_module_init(np, ti_32k_timer.base);
> + ti_32k_timer_moduleule_init(np, ti_32k_timer.base);
Even more crazy mindless and completely incorrect changes.
> diff --git a/drivers/scsi/bfa/bfa_ioc.c b/drivers/scsi/bfa/bfa_ioc.c
> index aa68d61a2d0d..4c11e3738f36 100644
> --- a/drivers/scsi/bfa/bfa_ioc.c
> +++ b/drivers/scsi/bfa/bfa_ioc.c
> #define bfa_ioc_timer_start(__ioc) \
> - bfa_timer_begin((__ioc)->timer_mod, &(__ioc)->ioc_timer, \
> + bfa_timer_begin((__ioc)->timer_module, &(__ioc)->ioc_timer, \
As far as I can tell, this is the *only* correct conversion, with 95%
of the patch just being complete garbage.
Stop doing search-and-replace.
Linus
Powered by blists - more mailing lists