[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <174461735124.31282.10048527543027738159.tip-bot2@tip-bot2>
Date: Mon, 14 Apr 2025 07:55:51 -0000
From: "tip-bot2 for Ingo Molnar" <tip-bot2@...utronix.de>
To: linux-tip-commits@...r.kernel.org
Cc: kernel test robot <lkp@...el.com>, Ingo Molnar <mingo@...nel.org>,
x86@...nel.org, linux-kernel@...r.kernel.org
Subject: [tip: x86/alternatives] x86/alternatives, um: Rename UML's
text_poke_sync() wrapper to smp_text_poke_sync_each_cpu()
The following commit has been merged into the x86/alternatives branch of tip:
Commit-ID: f99002b9a9cc441a8f362e6fb32cf8a5a990261a
Gitweb: https://git.kernel.org/tip/f99002b9a9cc441a8f362e6fb32cf8a5a990261a
Author: Ingo Molnar <mingo@...nel.org>
AuthorDate: Mon, 14 Apr 2025 09:39:33 +02:00
Committer: Ingo Molnar <mingo@...nel.org>
CommitterDate: Mon, 14 Apr 2025 09:42:22 +02:00
x86/alternatives, um: Rename UML's text_poke_sync() wrapper to smp_text_poke_sync_each_cpu()
Missed this UML wrapper in the rename.
Fixes: 6e4955a9d73e ("x86/alternatives: Rename 'text_poke_sync()' to 'smp_text_poke_sync_each_cpu()'")
Reported-by: kernel test robot <lkp@...el.com>
Signed-off-by: Ingo Molnar <mingo@...nel.org>
Link: https://lore.kernel.org/r/202504141003.kc69fVoj-lkp@intel.com
---
arch/um/kernel/um_arch.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/um/kernel/um_arch.c b/arch/um/kernel/um_arch.c
index d4b3b67..2f5ee04 100644
--- a/arch/um/kernel/um_arch.c
+++ b/arch/um/kernel/um_arch.c
@@ -477,7 +477,7 @@ void *text_poke_copy(void *addr, const void *opcode, size_t len)
return text_poke(addr, opcode, len);
}
-void text_poke_sync(void)
+void smp_text_poke_sync_each_cpu(void)
{
}
Powered by blists - more mailing lists