[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <966960bf-0d5a-4e1f-af77-b573c3d1e1cb@kernel.org>
Date: Mon, 14 Apr 2025 10:01:41 +0200
From: Jiri Slaby <jirislaby@...nel.org>
To: Praveen Talari <quic_ptalari@...cinc.com>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Rob Herring <robh@...nel.org>, Krzysztof Kozlowski <krzk+dt@...nel.org>,
Conor Dooley <conor+dt@...nel.org>, Bjorn Andersson <andersson@...nel.org>,
Konrad Dybcio <konradybcio@...nel.org>, Viresh Kumar <vireshk@...nel.org>,
Nishanth Menon <nm@...com>, Stephen Boyd <sboyd@...nel.org>,
"Rafael J. Wysocki" <rafael@...nel.org>, linux-arm-msm@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-serial@...r.kernel.org,
devicetree@...r.kernel.org, linux-pm@...r.kernel.org
Cc: psodagud@...cinc.com, djaggi@...cinc.com, quic_msavaliy@...cinc.com,
quic_vtanuku@...cinc.com, quic_arandive@...cinc.com,
quic_mnaresh@...cinc.com, quic_shazhuss@...cinc.com
Subject: Re: [PATCH v1 7/9] serial: qcom-geni: move clock-rate logic to
separate function
On 10. 04. 25, 19:40, Praveen Talari wrote:
> Facilitates future modifications within the new function,
> leading to better readability and maintainability of the code.
>
> Move the code that handles the actual logic of clock-rate
> calculations to a separate function geni_serial_set_rate()
> which enhances code readability.
>
> Signed-off-by: Praveen Talari <quic_ptalari@...cinc.com>
> ---
> drivers/tty/serial/qcom_geni_serial.c | 56 +++++++++++++++++----------
> 1 file changed, 36 insertions(+), 20 deletions(-)
>
> diff --git a/drivers/tty/serial/qcom_geni_serial.c b/drivers/tty/serial/qcom_geni_serial.c
> index e341f5090ecc..25d16ac3f406 100644
> --- a/drivers/tty/serial/qcom_geni_serial.c
> +++ b/drivers/tty/serial/qcom_geni_serial.c
...
> @@ -1323,6 +1310,37 @@ static void qcom_geni_serial_set_termios(struct uart_port *uport,
> port->se.icc_paths[CPU_TO_GENI].avg_bw = Bps_to_icc(baud);
> geni_icc_set_bw(&port->se);
>
> + writel(ser_clk_cfg, uport->membase + GENI_SER_M_CLK_CFG);
> + writel(ser_clk_cfg, uport->membase + GENI_SER_S_CLK_CFG);
> + return 0;
Did this pass checkpatch?
> +}
> +
> +static void qcom_geni_serial_set_termios(struct uart_port *uport,
> + struct ktermios *termios,
> + const struct ktermios *old)
> +{
> + struct qcom_geni_serial_port *port = to_dev_port(uport);
> + unsigned int baud;
> + unsigned long timeout;
> + u32 bits_per_char;
> + u32 tx_trans_cfg;
> + u32 tx_parity_cfg;
> + u32 rx_trans_cfg;
> + u32 rx_parity_cfg;
> + u32 stop_bit_len;
> + int ret = 0;
> +
> + /* baud rate */
> + baud = uart_get_baud_rate(uport, termios, old, 300, 4000000);
> +
> + ret = geni_serial_set_rate(uport, baud);
> + if (ret) {
> + dev_err(port->se.dev,
> + "%s: Failed to set baud: %u ret: %d\n",
Why the doubled spaces?
> + __func__, baud, ret);
> + return;
> + }
> +
> /* parity */
> tx_trans_cfg = readl(uport->membase + SE_UART_TX_TRANS_CFG);
> tx_parity_cfg = readl(uport->membase + SE_UART_TX_PARITY_CFG);
thanks,
--
js
suse labs
Powered by blists - more mailing lists