[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <f090fcbf-5593-2e37-efc7-3ec14990ab27@huawei.com>
Date: Mon, 14 Apr 2025 17:13:20 +0800
From: Jinjie Ruan <ruanjinjie@...wei.com>
To: <catalin.marinas@....com>, <will@...nel.org>, <oleg@...hat.com>,
<sstabellini@...nel.org>, <tglx@...utronix.de>, <peterz@...radead.org>,
<luto@...nel.org>, <mingo@...hat.com>, <juri.lelli@...hat.com>,
<vincent.guittot@...aro.org>, <dietmar.eggemann@....com>,
<rostedt@...dmis.org>, <bsegall@...gle.com>, <mgorman@...e.de>,
<vschneid@...hat.com>, <kees@...nel.org>, <aliceryhl@...gle.com>,
<ojeda@...nel.org>, <samitolvanen@...gle.com>, <masahiroy@...nel.org>,
<rppt@...nel.org>, <xur@...gle.com>, <paulmck@...nel.org>, <arnd@...db.de>,
<mark.rutland@....com>, <puranjay@...nel.org>, <broonie@...nel.org>,
<mbenes@...e.cz>, <sudeep.holla@....com>, <guohanjun@...wei.com>,
<prarit@...hat.com>, <liuwei09@...tc.cn>, <Jonathan.Cameron@...wei.com>,
<dwmw@...zon.co.uk>, <kristina.martsenko@....com>, <liaochang1@...wei.com>,
<ptosi@...gle.com>, <thiago.bauermann@...aro.org>, <kevin.brodsky@....com>,
<Dave.Martin@....com>, <joey.gouly@....com>, <linux-kernel@...r.kernel.org>,
<linux-arm-kernel@...ts.infradead.org>, <xen-devel@...ts.xenproject.org>
Subject: Re: [PATCH -next v6 0/8] arm64: entry: Convert to generic irq entry
On 2025/2/13 20:59, Jinjie Ruan wrote:
> Currently, x86, Riscv, Loongarch use the generic entry. Convert arm64
> to use the generic entry infrastructure from kernel/entry/*. The generic
> entry makes maintainers' work easier and codes more elegant, which will
> make PREEMPT_DYNAMIC and PREEMPT_LAZY available and remove a lot of
> duplicate code.
>
> This patch series split the generic entry into generic irq entry and
> generic syscall entry first, and then convert arm64 to use the generic
> irq entry. arm64 will be completely converted to generic entry in another
> patch series.
>
> The main convert steps are as follows:
> - Split generic entry into generic irq entry and generic syscall to
> make the single patch more concentrated in switching to one thing.
> - Make arm64 easier to use irqentry_enter/exit().
> - Make arm64 closer to the PREEMPT_DYNAMIC code of generic entry.
> - Switch to generic irq entry.
Gentle Ping.
>
> Changes in v6:
> - Rebased on 6.14 rc2 next.
> - Put the syscall bits aside and split it out.
> - Have the split patch before the arm64 changes.
> - Merge some tightly coupled patches.
> - Adjust the order of some patches to make them more reasonable.
> - Define regs_irqs_disabled() by inline function.
> - Define interrupts_enabled() in terms of regs_irqs_disabled().
> - Delete the fast_interrupts_enabled() macro.
> - irqentry_state_t -> arm64_irqentry_state_t.
> - Remove arch_exit_to_user_mode_prepare() and pull local_daif_mask() later
> in the arm64 exit sequence
> - Update the commit message.
>
> Changes in v5:
> - Not change arm32 and keep inerrupts_enabled() macro for gicv3 driver.
> - Move irqentry_state definition into arch/arm64/kernel/entry-common.c.
> - Avoid removing the __enter_from_*() and __exit_to_*() wrappers.
> - Update "irqentry_state_t ret/irq_state" to "state"
> to keep it consistently.
> - Use generic irq entry header for PREEMPT_DYNAMIC after split
> the generic entry.
> - Also refactor the ARM64 syscall code.
> - Introduce arch_ptrace_report_syscall_entry/exit(), instead of
> arch_pre/post_report_syscall_entry/exit() to simplify code.
> - Make the syscall patches clear separation.
> - Update the commit message.
>
> Changes in v4:
> - Rework/cleanup split into a few patches as Mark suggested.
> - Replace interrupts_enabled() macro with regs_irqs_disabled(), instead
> of left it here.
> - Remove rcu and lockdep state in pt_regs by using temporary
> irqentry_state_t as Mark suggested.
> - Remove some unnecessary intermediate functions to make it clear.
> - Rework preempt irq and PREEMPT_DYNAMIC code
> to make the switch more clear.
> - arch_prepare_*_entry/exit() -> arch_pre_*_entry/exit().
> - Expand the arch functions comment.
> - Make arch functions closer to its caller.
> - Declare saved_reg in for block.
> - Remove arch_exit_to_kernel_mode_prepare(), arch_enter_from_kernel_mode().
> - Adjust "Add few arch functions to use generic entry" patch to be
> the penultimate.
> - Update the commit message.
> - Add suggested-by.
>
> Changes in v3:
> - Test the MTE test cases.
> - Handle forget_syscall() in arch_post_report_syscall_entry()
> - Make the arch funcs not use __weak as Thomas suggested, so move
> the arch funcs to entry-common.h, and make arch_forget_syscall() folded
> in arch_post_report_syscall_entry() as suggested.
> - Move report_single_step() to thread_info.h for arm64
> - Change __always_inline() to inline, add inline for the other arch funcs.
> - Remove unused signal.h for entry-common.h.
> - Add Suggested-by.
> - Update the commit message.
>
> Changes in v2:
> - Add tested-by.
> - Fix a bug that not call arch_post_report_syscall_entry() in
> syscall_trace_enter() if ptrace_report_syscall_entry() return not zero.
> - Refactor report_syscall().
> - Add comment for arch_prepare_report_syscall_exit().
> - Adjust entry-common.h header file inclusion to alphabetical order.
> - Update the commit message.
>
> Jinjie Ruan (8):
> entry: Split generic entry into generic exception and syscall entry
> arm64: ptrace: Replace interrupts_enabled() with regs_irqs_disabled()
> arm64: entry: Refactor the entry and exit for exceptions from EL1
> arm64: entry: Rework arm64_preempt_schedule_irq()
> arm64: entry: Use preempt_count() and need_resched() helper
> arm64: entry: Refactor preempt_schedule_irq() check code
> arm64: entry: Move arm64_preempt_schedule_irq() into
> __exit_to_kernel_mode()
> arm64: entry: Switch to generic IRQ entry
>
> MAINTAINERS | 1 +
> arch/Kconfig | 9 +
> arch/arm64/Kconfig | 1 +
> arch/arm64/include/asm/daifflags.h | 2 +-
> arch/arm64/include/asm/entry-common.h | 56 ++++
> arch/arm64/include/asm/preempt.h | 2 -
> arch/arm64/include/asm/ptrace.h | 13 +-
> arch/arm64/include/asm/xen/events.h | 2 +-
> arch/arm64/kernel/acpi.c | 2 +-
> arch/arm64/kernel/debug-monitors.c | 2 +-
> arch/arm64/kernel/entry-common.c | 378 ++++++++-----------------
> arch/arm64/kernel/sdei.c | 2 +-
> arch/arm64/kernel/signal.c | 3 +-
> include/linux/entry-common.h | 382 +------------------------
> include/linux/irq-entry-common.h | 389 ++++++++++++++++++++++++++
> kernel/entry/Makefile | 3 +-
> kernel/entry/common.c | 176 ++----------
> kernel/entry/syscall-common.c | 159 +++++++++++
> kernel/sched/core.c | 8 +-
> 19 files changed, 766 insertions(+), 824 deletions(-)
> create mode 100644 arch/arm64/include/asm/entry-common.h
> create mode 100644 include/linux/irq-entry-common.h
> create mode 100644 kernel/entry/syscall-common.c
>
Powered by blists - more mailing lists