lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <f998cbba-bda0-472b-8f4a-a972a29f21ef@arm.com>
Date: Tue, 15 Apr 2025 12:06:31 +0530
From: Anshuman Khandual <anshuman.khandual@....com>
To: Seongsu Park <sgsu.park@...sung.com>, will@...nel.org,
 catalin.marinas@....com, yuzenghui@...wei.com, suzuki.poulose@....com,
 joey.gouly@....com, oliver.upton@...ux.dev, maz@...nel.org
Cc: linux-arm-kernel@...ts.infradead.org, kvmarm@...ts.linux.dev,
 linux-kernel@...r.kernel.org, cpgs@...sung.com
Subject: Re: [PATCH] arm64: kvm: Replace ternary flags with str_on_off()
 helper



On 4/15/25 06:54, Seongsu Park wrote:
> Replace repetitive ternary expressions with the str_on_off() helper
> function. This change improves code readability and ensures consistency
> in tracepoint string formatting
> 
> Signed-off-by: Seongsu Park <sgsu.park@...sung.com>
> ---
>  arch/arm64/kvm/trace_arm.h | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/arch/arm64/kvm/trace_arm.h b/arch/arm64/kvm/trace_arm.h
> index c18c1a95831e..9c60f6465c78 100644
> --- a/arch/arm64/kvm/trace_arm.h
> +++ b/arch/arm64/kvm/trace_arm.h
> @@ -176,7 +176,7 @@ TRACE_EVENT(kvm_set_way_flush,
>  	    ),
>  
>  	    TP_printk("S/W flush at 0x%016lx (cache %s)",
> -		      __entry->vcpu_pc, __entry->cache ? "on" : "off")
> +		      __entry->vcpu_pc, str_on_off(__entry->cache))
>  );
>  
>  TRACE_EVENT(kvm_toggle_cache,
> @@ -196,8 +196,8 @@ TRACE_EVENT(kvm_toggle_cache,
>  	    ),
>  
>  	    TP_printk("VM op at 0x%016lx (cache was %s, now %s)",
> -		      __entry->vcpu_pc, __entry->was ? "on" : "off",
> -		      __entry->now ? "on" : "off")
> +		      __entry->vcpu_pc, str_on_off(__entry->was),
> +		      str_on_off(__entry->now))
>  );
>  
>  /*

Reviewed-by: Anshuman Khandual <anshuman.khandual@....com>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ