[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <aedaf79b-7bd3-885c-2bcf-ab9c73f7cf86@outbound.gmail.com>
Date: Tue, 15 Apr 2025 12:46:51 +0300
From: Eli Billauer <eli.billauer@...il.com>
To: Chen Ni <nichen@...as.ac.cn>, arnd@...db.de, gregkh@...uxfoundation.org
Cc: linux-kernel@...r.kernel.org
Subject: Re: [PATCH] char: xillybus: Use to_delayed_work()
Yes, I suppose this is the right way to do it.
Thanks,
Eli
Acked-by: Eli Billauer <eli.billauer@...il.com>
On 14/04/2025 10:45, Chen Ni wrote:
> Use to_delayed_work() instead of open-coding it.
>
> Signed-off-by: Chen Ni <nichen@...as.ac.cn>
> ---
> drivers/char/xillybus/xillybus_core.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/char/xillybus/xillybus_core.c b/drivers/char/xillybus/xillybus_core.c
> index 11b7c4749274..efb1ae834265 100644
> --- a/drivers/char/xillybus/xillybus_core.c
> +++ b/drivers/char/xillybus/xillybus_core.c
> @@ -1184,8 +1184,7 @@ static int xillybus_flush(struct file *filp, fl_owner_t id)
>
> static void xillybus_autoflush(struct work_struct *work)
> {
> - struct delayed_work *workitem = container_of(
> - work, struct delayed_work, work);
> + struct delayed_work *workitem = to_delayed_work(work);
> struct xilly_channel *channel = container_of(
> workitem, struct xilly_channel, rd_workitem);
> int rc;
Powered by blists - more mailing lists