[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4edcefb0-cdbd-4422-8a08-ffc091de158e@paulmck-laptop>
Date: Fri, 18 Apr 2025 10:13:49 -0700
From: "Paul E. McKenney" <paulmck@...nel.org>
To: linux-kernel@...r.kernel.org
Cc: Andrew Morton <akpm@...ux-foundation.org>,
Kuniyuki Iwashima <kuniyu@...zon.com>,
Mateusz Guzik <mjguzik@...il.com>, Petr Mladek <pmladek@...e.com>,
Steven Rostedt <rostedt@...dmis.org>,
John Ogness <john.ogness@...utronix.de>,
Sergey Senozhatsky <senozhatsky@...omium.org>,
Jon Pan-Doh <pandoh@...gle.com>,
Bjorn Helgaas <bhelgaas@...gle.com>,
Karolina Stolarek <karolina.stolarek@...cle.com>
Subject: Re: [PATCH RFC 0/9] Reduce ratelimit's false-positive misses
Hello!
This v2 series replaces open-coded uses of the ratelimit_state structure
with formal APIs, counts all rate-limit misses, replaces jiffies=0 special
case with a flag, provides a ___ratelimit() trylock-failure fastpath
to (almost) eliminate false-positive misses, and adds a simple test.
The key point of this series is the reduction of false-positive misses.
The individual patches are as follows:
1. Add trivial kunit test for ratelimit.
2. Create functions to handle ratelimit_state internals.
3. Avoid open-coded use of ratelimit_state structure's ->missed
field.
4. Avoid open-coded use of ratelimit_state structure's ->missed
field.
5. Avoid open-coded use of ratelimit_state structure's internals.
6. Convert the ->missed field to atomic_t.
7. Count misses due to lock contention.
8. Avoid jiffies=0 special case.
9. Reduce ___ratelimit() false-positive rate limiting, courtesy of
Petr Mladek.
10. Allow zero ->burst to disable ratelimiting.
11. Force re-initialization when rate-limiting re-enabled.
12. Don't flush misses counter if RATELIMIT_MSG_ON_RELEASE.
13. Avoid atomic decrement if already rate-limited.
14. Avoid atomic decrement under lock if already rate-limited.
Changes since v1 (RFC):
o Switch from lockless fastpath to carrying out needed updates
upon trylock failure, per Petr Mladek feedback. This greatly
simplifies the code and is a much smaller change from the
current code. There is a small performance penalty compared to
the lockless fastpath, but not enough to matter.
o Never unconditionally acquire the lock, again per Petr Mladek
feedback.
o Better define effects of non-positive burst values (always
ratelimit) and non-positive interval values (never ratelimit
when the burst value is positive).
o The changes from Petr's original are supplied as five incremental
patches, but could easily be folded into Petr's original if
desired. (Left to my lazy self, they stay as-is.)
Thanx, Paul
------------------------------------------------------------------------
b/drivers/char/random.c | 9 +--
b/drivers/gpu/drm/amd/pm/amdgpu_pm.c | 11 ---
b/drivers/gpu/drm/i915/i915_perf.c | 8 +-
b/include/linux/ratelimit.h | 40 ++++++++++++-
b/include/linux/ratelimit_types.h | 2
b/lib/Kconfig.debug | 11 +++
b/lib/Makefile | 1
b/lib/ratelimit.c | 8 +-
b/lib/test_ratelimit.c | 79 +++++++++++++++++++++++++++
include/linux/ratelimit.h | 13 +---
include/linux/ratelimit_types.h | 3 -
lib/ratelimit.c | 102 +++++++++++++++++++++++++----------
12 files changed, 223 insertions(+), 64 deletions(-)
Powered by blists - more mailing lists