[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <cover.1744966511.git.abrahamadekunle50@gmail.com>
Date: Fri, 18 Apr 2025 09:47:53 +0000
From: Abraham Samuel Adekunle <abrahamadekunle50@...il.com>
To: julia.lawall@...ia.fr,
gregkh@...uxfoundation.org
Cc: linux-staging@...ts.linux.dev,
linux-kernel@...r.kernel.org,
david.laight.linux@...il.com,
dan.carpenter@...aro.org,
andy@...nel.org,
Abraham Samuel Adekunle <abrahamadekunle50@...il.com>
Subject: [PATCH v11 0/2] staging: rtl8723bs: Improve readability and clarity of sequence number wrapping
The patchset adds spaces around binary operators, breaks long lines to enhance readability
and provides clarity on sequence number wrapping by using a modulo operation % 4096u, in
place of the bitwise AND(&) operation & 0xfff.
The patches are required to be applied in sequence.
Changes in v10:
- Sent v11 to mailing list after v10 was deleted due to versioning mistake.
Changes in v9:
* PATCH 1:
- Added more converted cases found in the driver to the patch.
- The Coccinelle semantic patch used to find additional cases in the driver is:
@@
expression e;
@@
* e & 0xfff
- The bloat-o-meter tool was used to ensure the sizes of the binary
files before and after the change were the same.
- $ make drivers/staging/rtl8723bs/core/rtw_xmit.o
$ ./scripts/bloat-o-meter rtw_xmit_before.o rtw_xmit_after.o
This showed identical 'Before' and 'After' size values with a 'chg' of +0.00%.
Changes in v8:
* PATCH 1:
- Added Reviewed-by tag to commit message.
* PATCH 2:
- Added Reviewed-by tag to commit message.
Changes in v7:
* PATCH 1:
- Added blank line to enhance readability
* PATCH 2:
- Changed `power of 2` to `power-of-2` in commit message.
Changes in v6:
- Modified cover letter BLURB to reference newly added line breaks.
* PATCH 1:
- Added line breaks to long lines to improve readability.
- Changed commit message to include the information about the broken
lines added to the patch.
- Changed subject line title to also include the newly added line breaks.
* PATCH 2:
- Changed instances of `& 0xfff` to `% 4096u` which were now in the broken lines
after the broken lines have been done in PATCH 1.
Changes in v5:
- Converted the patch with the subject "Use % 4096 instead of & 0xfff"
patch to a patchset.
- Added a patch to add spaces around binary operator.
Changes in v4:
- Corrected patch to use '%' instead of '&'.
- To ensure this change does not affect the functional
behaviour, I compared the generated object files before and
after the change using the `cmp` which compares the two
object files byte by byte as shown below:
$ make drivers/staging/rtl8723bs/core/rtw_xmit.o
$ cmp rtw_xmit_before.o rtw_xmit_after.o
No differences were found in the output, confirming that the
change does not alter the compiled output.
Changes in v3:
- Added more description to the commit message.
- Removed blank line in the tag block.
- Added more patch recipients.
Changes in v2:
- Changed the commit message t a more descriptive message which
makes it clear why the patch does the change.
- changed the subject title to include `4096u` to show that an
unsigned module is used.
Changes in v1:
- Added more patch recipients.
Abraham Samuel Adekunle (2):
staging: rtl8723bs: Add spaces and line breaks to improve readability
staging: rtl8723bs: Use % 4096 instead of & 0xfff
drivers/staging/rtl8723bs/core/rtw_mlme_ext.c | 2 +-
drivers/staging/rtl8723bs/core/rtw_recv.c | 6 +++---
drivers/staging/rtl8723bs/core/rtw_xmit.c | 9 ++++++---
3 files changed, 10 insertions(+), 7 deletions(-)
--
2.34.1
Powered by blists - more mailing lists