[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20250421015823.32009-1-ye.liu@linux.dev>
Date: Mon, 21 Apr 2025 09:58:23 +0800
From: Ye Liu <ye.liu@...ux.dev>
To: akpm@...ux-foundation.org,
nao.horiguchi@...il.com,
linmiaohe@...wei.com
Cc: linux-kernel@...r.kernel.org,
linux-mm@...ck.org,
lorenzo.stoakes@...cle.com,
Liam.Howlett@...cle.com,
david@...hat.com,
harry.yoo@...cle.com,
riel@...riel.com,
vbabka@...e.cz,
liuye@...inos.cn,
ye.liu@...ux.dev
Subject: [PATCH v3] mm/rmap: rename page__anon_vma to anon_vma for consistency
From: Ye Liu <liuye@...inos.cn>
Renamed local variable page__anon_vma in page_address_in_vma() to
anon_vma. The previous naming convention of using double underscores
(__) is unnecessary and inconsistent with typical kernel style, which uses
single underscores to denote local variables. Also updated comments to
reflect the new variable name.
Functionality unchanged.
Signed-off-by: Ye Liu <liuye@...inos.cn>
Changes in v3:
- Rename variable from page_anon_vma to anon_vma.
---
mm/rmap.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/mm/rmap.c b/mm/rmap.c
index 67bb273dfb80..447e5b57e44f 100644
--- a/mm/rmap.c
+++ b/mm/rmap.c
@@ -789,13 +789,13 @@ unsigned long page_address_in_vma(const struct folio *folio,
const struct page *page, const struct vm_area_struct *vma)
{
if (folio_test_anon(folio)) {
- struct anon_vma *page__anon_vma = folio_anon_vma(folio);
+ struct anon_vma *anon_vma = folio_anon_vma(folio);
/*
* Note: swapoff's unuse_vma() is more efficient with this
* check, and needs it to match anon_vma when KSM is active.
*/
- if (!vma->anon_vma || !page__anon_vma ||
- vma->anon_vma->root != page__anon_vma->root)
+ if (!vma->anon_vma || !anon_vma ||
+ vma->anon_vma->root != anon_vma->root)
return -EFAULT;
} else if (!vma->vm_file) {
return -EFAULT;
@@ -803,7 +803,7 @@ unsigned long page_address_in_vma(const struct folio *folio,
return -EFAULT;
}
- /* KSM folios don't reach here because of the !page__anon_vma check */
+ /* KSM folios don't reach here because of the !anon_vma check */
return vma_address(vma, page_pgoff(folio, page), 1);
}
--
2.25.1
Powered by blists - more mailing lists