lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <f01cb2d7-d69c-1565-d3e4-09c4b70856f6@huaweicloud.com>
Date: Mon, 21 Apr 2025 21:13:57 +0800
From: Yu Kuai <yukuai1@...weicloud.com>
To: Christoph Hellwig <hch@...radead.org>, Yu Kuai <yukuai1@...weicloud.com>
Cc: axboe@...nel.dk, xni@...hat.com, agk@...hat.com, snitzer@...nel.org,
 mpatocka@...hat.com, song@...nel.org, viro@...iv.linux.org.uk,
 akpm@...ux-foundation.org, nadav.amit@...il.com, ubizjak@...il.com,
 cl@...ux.com, linux-block@...r.kernel.org, linux-kernel@...r.kernel.org,
 dm-devel@...ts.linux.dev, linux-raid@...r.kernel.org, yi.zhang@...wei.com,
 yangerkun@...wei.com, johnny.chenyi@...wei.com,
 "yukuai (C)" <yukuai3@...wei.com>
Subject: Re: [PATCH v2 1/5] block: cleanup and export bdev IO inflight APIs

Hi,

在 2025/04/21 19:59, Christoph Hellwig 写道:
> On Fri, Apr 18, 2025 at 09:09:37AM +0800, Yu Kuai wrote:
>> - remove unused blk_mq_in_flight
> 
> That should probably be a separate patch.
ok

> 
>> - rename blk_mq_in_flight_rw to blk_mq_count_in_driver_rw, to distinguish
>>    from bdev_count_inflight_rw.
> 
> I'm not sure why this is needed or related, or even what additional
> distinction is added here.

Because for rq-based device, there are two different stage,
blk_account_io_start() while allocating new rq, and
blk_mq_start_request() while issuing the rq to driver.

When will we think the reqeust is inflight? For iostat, my anser is the
former one, because rq->start_time_ns is set here as well. And noted in
iostats api diskstats_show(/proc/diskstats) and part_stat_show
(/sys/block/sda/stat), inflight is get by part_in_flight, which is
different from disk sysfs api(/sys/block/sda/inflight).

> 
>> -
>> -void blk_mq_in_flight_rw(struct request_queue *q, struct block_device *part,
>> -		unsigned int inflight[2])
>> +void blk_mq_count_in_driver_rw(struct request_queue *q,
>> +			       struct block_device *part,
>> +			       unsigned int inflight[2])
> 
> Any reason to move away from two tab indents for the prototype
> continuations in various places in this patch?
> 
>> + * Noted, for rq-based block device, use blk_mq_count_in_driver_rw() to get the
>> + * number of requests issued to driver.
> 
> I'd just change this helper to call blk_mq_count_in_driver_rw for
> blk-mq devices and remove the conditional from the sysfs code instead.
> That gives us a much more robust and easier to understand API.

Ok, and another separate patch, right?
> 
>> +void bdev_count_inflight_rw(struct block_device *bdev, unsigned int inflight[2]);
> 
> Overly long line.
> 
>> +static inline unsigned int bdev_count_inflight(struct block_device *bdev)
>> +{
>> +	unsigned int inflight[2];
>> +
>> +	bdev_count_inflight_rw(bdev, inflight);
>> +
>> +	return inflight[0] + inflight[1];
>> +}
>>   #endif /* _LINUX_PART_STAT_H */
> 
> Maybe keep this inside of block as it should not not be used by
> drivers?  Also the reimplementation should probably be a separate
> patch from the public API change and exporting.

ok, and I should probably send the first set just related to this patch
first.

Thanks,
Kuai

> 
> .
> 


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ