[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20250422123902.2019685-1-o.rempel@pengutronix.de>
Date: Tue, 22 Apr 2025 14:38:58 +0200
From: Oleksij Rempel <o.rempel@...gutronix.de>
To: "David S. Miller" <davem@...emloft.net>,
Eric Dumazet <edumazet@...gle.com>,
Jakub Kicinski <kuba@...nel.org>,
Paolo Abeni <pabeni@...hat.com>,
Simon Horman <horms@...nel.org>
Cc: Oleksij Rempel <o.rempel@...gutronix.de>,
kernel@...gutronix.de,
linux-kernel@...r.kernel.org,
netdev@...r.kernel.org,
Maxime Chevallier <maxime.chevallier@...tlin.com>
Subject: [PATCH net-next v2 0/4] net: selftest: improve test string formatting and checksum handling
This patchset addresses two issues in the current net selftest
framework:
- Truncated test names: Existing test names are prefixed with an index,
reducing the available space within the ETH_GSTRING_LEN limit. This
patch removes the index to allow more descriptive names.
- Inconsistent checksum behavior: On DSA setups and similar
environments, checksum offloading is not always available or
appropriate. The previous selftests did not distinguish between software
and hardware checksum modes, leading to unreliable results. This
patchset introduces explicit csum_mode handling and adds separate tests
for both software and hardware checksum validation.
Oleksij Rempel (4):
net: selftests: drop test index from net_selftest_get_strings()
net: selftests: prepare for detailed error handling in
net_test_get_skb()
net: selftests: add checksum mode support and SW checksum handling
net: selftests: add PHY loopback tests with HW checksum offload
net/core/selftests.c | 308 ++++++++++++++++++++++++++++++++++++++++---
1 file changed, 291 insertions(+), 17 deletions(-)
--
2.39.5
Powered by blists - more mailing lists