[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <9b76db16-75a1-412a-8a94-28768ea56a1e@redhat.com>
Date: Tue, 22 Apr 2025 10:55:28 +0200
From: David Hildenbrand <david@...hat.com>
To: nifan.cxl@...il.com, muchun.song@...ux.dev, willy@...radead.org
Cc: mcgrof@...nel.org, a.manzanares@...sung.com, dave@...olabs.net,
akpm@...ux-foundation.org, linux-mm@...ck.org, linux-kernel@...r.kernel.org,
Fan Ni <fan.ni@...sung.com>, Sidhartha Kumar <sidhartha.kumar@...cle.com>
Subject: Re: [PATCH v2 2/4] mm/hugetlb: Refactor unmap_hugepage_range() to
take folio instead of page
On 18.04.25 18:57, nifan.cxl@...il.com wrote:
> From: Fan Ni <fan.ni@...sung.com>
>
> The function unmap_hugepage_range() has two kinds of users:
> 1) unmap_ref_private(), which passes in the head page of a folio. Since
> unmap_ref_private() already takes folio and there are no other uses
> of the folio struct in the function, it is natural for
> unmap_hugepage_range() to take folio also.
> 2) All other uses, which pass in NULL pointer.
>
> In both cases, we can pass in folio. Refactor unmap_hugepage_range() to
> take folio.
>
> Signed-off-by: Fan Ni <fan.ni@...sung.com>
> Reviewed-by: Muchun Song <muchun.song@...ux.dev>
> Reviewed-by: Sidhartha Kumar <sidhartha.kumar@...cle.com>
> ---
> v2:
> Picked up Reviewed-by tags;
>
> v1:
> https://lore.kernel.org/linux-mm/aAHUluy7T32ZlYg7@debian/T/#m7ba630d783e08ae708453279579093d481c6e721
> ---
> include/linux/hugetlb.h | 2 +-
> mm/hugetlb.c | 7 ++++---
> 2 files changed, 5 insertions(+), 4 deletions(-)
>
> diff --git a/include/linux/hugetlb.h b/include/linux/hugetlb.h
> index a57bed83c657..b7699f35c87f 100644
> --- a/include/linux/hugetlb.h
> +++ b/include/linux/hugetlb.h
> @@ -128,7 +128,7 @@ int move_hugetlb_page_tables(struct vm_area_struct *vma,
> int copy_hugetlb_page_range(struct mm_struct *, struct mm_struct *,
> struct vm_area_struct *, struct vm_area_struct *);
> void unmap_hugepage_range(struct vm_area_struct *,
> - unsigned long, unsigned long, struct page *,
> + unsigned long, unsigned long, struct folio *folio,
> zap_flags_t);
> void __unmap_hugepage_range(struct mmu_gather *tlb,
> struct vm_area_struct *vma,
> diff --git a/mm/hugetlb.c b/mm/hugetlb.c
> index b5d1ac8290a7..3181dbe0c4bb 100644
> --- a/mm/hugetlb.c
> +++ b/mm/hugetlb.c
> @@ -6039,7 +6039,7 @@ void __hugetlb_zap_end(struct vm_area_struct *vma,
> }
>
> void unmap_hugepage_range(struct vm_area_struct *vma, unsigned long start,
> - unsigned long end, struct page *ref_page,
> + unsigned long end, struct folio *ref_folio,
> zap_flags_t zap_flags)
Oh, and now I realize that you call it "folio" above and "ref_folio" here.
Can we just rename it to "folio" consistently or is there a reason to
use the weird "ref_" prefix?
--
Cheers,
David / dhildenb
Powered by blists - more mailing lists