lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <PH0PR11MB50957B606B76490E205923F8D6852@PH0PR11MB5095.namprd11.prod.outlook.com>
Date: Thu, 24 Apr 2025 15:24:08 +0000
From: "Keller, Jacob E" <jacob.e.keller@...el.com>
To: Jie Luo <quic_luoj@...cinc.com>, "Russell King (Oracle)"
	<linux@...linux.org.uk>
CC: Yury Norov <yury.norov@...il.com>, Rasmus Villemoes
	<linux@...musvillemoes.dk>, Julia Lawall <Julia.Lawall@...ia.fr>, "Nicolas
 Palix" <nicolas.palix@...g.fr>, Catalin Marinas <catalin.marinas@....com>,
	Will Deacon <will@...nel.org>, Marc Zyngier <maz@...nel.org>, Oliver Upton
	<oliver.upton@...ux.dev>, Joey Gouly <joey.gouly@....com>, Suzuki K Poulose
	<suzuki.poulose@....com>, Zenghui Yu <yuzenghui@...wei.com>,
	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
	"cocci@...ia.fr" <cocci@...ia.fr>, "linux-arm-kernel@...ts.infradead.org"
	<linux-arm-kernel@...ts.infradead.org>, "kvmarm@...ts.linux.dev"
	<kvmarm@...ts.linux.dev>, "andrew@...n.ch" <andrew@...n.ch>,
	"quic_kkumarcs@...cinc.com" <quic_kkumarcs@...cinc.com>,
	"quic_linchen@...cinc.com" <quic_linchen@...cinc.com>,
	"quic_leiwei@...cinc.com" <quic_leiwei@...cinc.com>,
	"quic_suruchia@...cinc.com" <quic_suruchia@...cinc.com>,
	"quic_pavir@...cinc.com" <quic_pavir@...cinc.com>
Subject: RE: [cocci] [PATCH v3 3/6] arm64: tlb: Convert the opencoded field
 modify



> -----Original Message-----
> From: cocci-request@...ia.fr <cocci-request@...ia.fr> On Behalf Of Jie Luo
> Sent: Wednesday, April 23, 2025 6:16 AM
> To: Russell King (Oracle) <linux@...linux.org.uk>
> Cc: Yury Norov <yury.norov@...il.com>; Rasmus Villemoes
> <linux@...musvillemoes.dk>; Julia Lawall <Julia.Lawall@...ia.fr>; Nicolas Palix
> <nicolas.palix@...g.fr>; Catalin Marinas <catalin.marinas@....com>; Will
> Deacon <will@...nel.org>; Marc Zyngier <maz@...nel.org>; Oliver Upton
> <oliver.upton@...ux.dev>; Joey Gouly <joey.gouly@....com>; Suzuki K Poulose
> <suzuki.poulose@....com>; Zenghui Yu <yuzenghui@...wei.com>; linux-
> kernel@...r.kernel.org; cocci@...ia.fr; linux-arm-kernel@...ts.infradead.org;
> kvmarm@...ts.linux.dev; andrew@...n.ch; quic_kkumarcs@...cinc.com;
> quic_linchen@...cinc.com; quic_leiwei@...cinc.com;
> quic_suruchia@...cinc.com; quic_pavir@...cinc.com
> Subject: Re: [cocci] [PATCH v3 3/6] arm64: tlb: Convert the opencoded field
> modify
> 
> 
> 
> On 4/18/2025 2:11 AM, Russell King (Oracle) wrote:
> > On Thu, Apr 17, 2025 at 06:47:10PM +0800, Luo Jie wrote:
> >> Replaced below code with the wrapper FIELD_MODIFY(MASK, &reg, val)
> >> - reg &= ~MASK;
> >> - reg |= FIELD_PREP(MASK, val);
> >> The semantic patch that makes this change is available
> >> in scripts/coccinelle/misc/field_modify.cocci.
> >>
> >> More information about semantic patching is available at
> >> https://coccinelle.gitlabpages.inria.fr/website
> >>
> >> Signed-off-by: Luo Jie <quic_luoj@...cinc.com>
> >> ---
> >>   arch/arm64/include/asm/tlbflush.h | 3 +--
> >>   1 file changed, 1 insertion(+), 2 deletions(-)
> >>
> >> diff --git a/arch/arm64/include/asm/tlbflush.h
> b/arch/arm64/include/asm/tlbflush.h
> >> index eba1a98657f1..0d250ef4161c 100644
> >> --- a/arch/arm64/include/asm/tlbflush.h
> >> +++ b/arch/arm64/include/asm/tlbflush.h
> >> @@ -112,8 +112,7 @@ static inline unsigned long get_trans_granule(void)
> >>   	    level >= 0 && level <= 3) {					\
> >>   		u64 ttl = level & 3;					\
> >>   		ttl |= get_trans_granule() << 2;			\
> >> -		arg &= ~TLBI_TTL_MASK;					\
> >> -		arg |= FIELD_PREP(TLBI_TTL_MASK, ttl);			\
> >> +		FIELD_MODIFY(TLBI_TTL_MASK, &arg, ttl);			\
> >
> > This could equally be:
> > 		arg = u64_replace_bits(arg, ttl, TLBI_TTL_MASK);
> >
> > which already exists, so doesn't require a new macro to be introduced.
> >
> Looks like the new macro FIELD_MODIFY() is accepted by Yury, maybe we
> can keep to use FIELD_MODIFY() with this change for better readability?

I'd prefer this version too rather than a pointer that modifies in place. Feels like it fits better with the other FIELD macros which don't take pointers and return their bits by value.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ