[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20250424-flexspipatch-v2-0-e9eb643e2286@nxp.com>
Date: Thu, 24 Apr 2025 15:33:24 +0800
From: Haibo Chen <haibo.chen@....com>
To: Haibo Chen <haibo.chen@....com>, Han Xu <han.xu@....com>,
Yogesh Gaur <yogeshgaur.83@...il.com>, Mark Brown <broonie@...nel.org>
Cc: linux-spi@...r.kernel.org, imx@...ts.linux.dev,
linux-kernel@...r.kernel.org
Subject: [PATCH v2 0/5] This patch set did some clean up and add runtime pm
support for flexspi driver
PATCH1/3/4 to clean up the code, make the code more readable
PATCH2 add the runtime pm support
PATCH5 use devm_add_action_or_reset() to replace remove() callback, this can avoid
oops when do bind/unbind test
Signed-off-by: Haibo Chen <haibo.chen@....com>
---
Changes in v2:
- only change the PATCH2, add #ifdef CONFIG_PM_SLEEP for nxp_fspi_suspend() to avoid build error
if CONFIG_PM=n and CONFIG_PM_SLEEP=y, no change for all other patches.
- Link to v1: https://lore.kernel.org/r/20250423-flexspipatch-v1-0-292e530509d3@nxp.com
---
Haibo Chen (4):
spi: spi-nxp-fspi: remove the goto in probe
spi: spi-nxp-fspi: enable runtime pm for fspi
spi: spi-nxp-fspi: use guard(mutex) to simplify the code
spi: spi-nxp-fspi: remove the unchecked return value for nxp_fspi_clk_disable_unprep
Han Xu (1):
spi: nxp-fspi: use devm instead of remove for driver detach
drivers/spi/spi-nxp-fspi.c | 191 ++++++++++++++++++++++++++-------------------
1 file changed, 111 insertions(+), 80 deletions(-)
---
base-commit: 2c9c612abeb38aab0e87d48496de6fd6daafb00b
change-id: 20250421-flexspipatch-1cf724d4213d
Best regards,
--
Haibo Chen <haibo.chen@....com>
Powered by blists - more mailing lists