[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250424010445.2260090-1-hans.zhang@cixtech.com>
Date: Thu, 24 Apr 2025 09:04:39 +0800
From: hans.zhang@...tech.com
To: bhelgaas@...gle.com,
lpieralisi@...nel.org,
kw@...ux.com,
manivannan.sadhasivam@...aro.org,
robh@...nel.org,
krzk+dt@...nel.org,
conor+dt@...nel.org
Cc: peter.chen@...tech.com,
linux-pci@...r.kernel.org,
devicetree@...r.kernel.org,
linux-kernel@...r.kernel.org,
Hans Zhang <hans.zhang@...tech.com>
Subject: [PATCH v4 0/5] Enhance the PCIe controller driver
From: Hans Zhang <hans.zhang@...tech.com>
Enhances the exiting Cadence PCIe controller drivers to support
HPA (High Performance Architecture) Cadence PCIe controllers.
The patch set enhances the Cadence PCIe driver for HPA support.
The "compatible" property in DTS is added with more enum to support
the new platform architecture and the register maps that change with
it. The driver read register and write register functions take the
updated offset stored from the platform driver to access the registers.
The driver now supports the legacy and HPA architecture, with the
legacy code changes beingminimal.
SoC related changes are not available in this patch set.
The TI SoC continues to be supported with the changes incorporated.
The changes are also in tune with how multiple platforms are supported
in related drivers.
The scripts/checkpatch.pl has been run on the patches with and without
--strict. With the --strict option, 4 checks are generated on 1 patch
(PATCH v3 3/6) of the series), which can be ignored. There are no code
fixes required for these checks. The rest of the 'scripts/checkpatch.pl'
is clean.
The ./scripts/kernel-doc --none have been run on the changed files.
The changes are tested on TI platforms. The legacy controller changes are
tested on an TI J7200 EVM and HPA changes are planned for on an FPGA
platform available within Cadence.
Changes for v4
- Add header file bitfield.h to pcie-cadence.h.
- Addressed the following review comments.
Merged the TI patch as it.
Removed initialization of struct variables to '0'.
Changes for v3
- Patch version v3 added to the subject.
- Use HPA tag for architecture descriptions.
- Remove bug related changes to be submitted later as a separate patch.
- Two patches merged from the last series to ensure readability to address
the review comments.
- Fix several description related issues, coding style issues and some
misleading comments.
- Remove cpu_addr_fixup() functions.
Manikandan K Pillai (5):
dt-bindings: pci: cadence: Extend compatible for new RP configuration
dt-bindings: pci: cadence: Extend compatible for new EP configurations
PCI: cadence: Add header support for PCIe HPA controller
PCI: cadence: Add support for PCIe Endpoint HPA controller
PCI: cadence: Add callback functions for RP and EP controller
.../bindings/pci/cdns,cdns-pcie-ep.yaml | 6 +-
.../bindings/pci/cdns,cdns-pcie-host.yaml | 6 +-
drivers/pci/controller/cadence/pci-j721e.c | 12 +
.../pci/controller/cadence/pcie-cadence-ep.c | 170 +++++++--
.../controller/cadence/pcie-cadence-host.c | 276 ++++++++++++--
.../controller/cadence/pcie-cadence-plat.c | 73 +++-
drivers/pci/controller/cadence/pcie-cadence.c | 197 +++++++++-
drivers/pci/controller/cadence/pcie-cadence.h | 340 +++++++++++++++++-
8 files changed, 1011 insertions(+), 69 deletions(-)
base-commit: fc96b232f8e7c0a6c282f47726b2ff6a5fb341d2
--
2.47.1
Powered by blists - more mailing lists